tomcat-taglibs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sgarlata Matt" <sgarlata_m...@bah.com>
Subject Re: ApplicationResources.properties apparently cached
Date Wed, 21 Jan 2004 14:21:13 GMT
Hi Adam -

As another shot in the dark, maybe in your build process you don't delete
old .properties files?  In the past I left out this step in my build process
and had strange results similar to what you are describing.  Have you
searched your filesystem for the old _de.properties file to see if it's
lingering somewhere?

Other than that, I too am stumped ...

Matt
----- Original Message ----- 
From: "Adam Hardy" <ahardy.struts@cyberspaceroad.com>
To: "Tag Libraries Users List" <taglibs-user@jakarta.apache.org>
Sent: Wednesday, January 21, 2004 6:03 AM
Subject: Re: ApplicationResources.properties apparently cached


> Thanks for the response. I know exactly how it must look to people
> reading this, but what you are suggesting is what I have been doing for
> the past week. I'm 99% positive that this is not a result of browser or
> proxy or JSP caching.
>
> On 01/21/2004 11:54 AM Evgeny Gesin wrote:
> > I think somethings can be wrong with application or
> > understanding how it works with bundle.properties, if
> > DE still cached. Try to remove compiled pages (under
> > the "work" directory in Tomcat), stop and start Tomcat
> > and point browser to the same pages again and see what
> > happen.
> >
> > Evgeny Gesin
> > Javadesk CEO / Founder
> >
> >
> > --- Adam Hardy <ahardy.struts@cyberspaceroad.com>
> > wrote:
> >
> >>Can anybody make any comment about this? Other than
> >>that you think I
> >>might be losing it?
> >>
> >>Thanks
> >>
> >>On 01/20/2004 06:38 PM Adam Hardy wrote:
> >>
> >>>I have set up my i18n properties files for use
> >>
> >>with the <fmt:message>
> >>
> >>>taglib (jstl 1.0) via the
> >>
> >>javax.servlet.jsp.jstl.fmt.localizationContext
> >>
> >>>and I tested it out with DE and EN to make sure my
> >>
> >>different locales on
> >>
> >>>the browser would generate the correct language
> >>
> >>text.
> >>
> >>>All worked, and so I deleted the German file,
> >>
> >>since it was only a test
> >>
> >>>and I'm not ready to do all the proper translation
> >>
> >>into German yet.
> >>
> >>>I deleted the _en.properties and _de.properties
> >>
> >>files, and have only a
> >>
> >>>default ApplicationResources.properties so I
> >>
> >>really can't see where the
> >>
> >>>old German strings are coming from.
> >>>
> >>>However the German strings keep appearing in my
> >>
> >>web pages in German
> >>
> >>>browsers.
> >>>
> >>>This has been troubling me for a month now and I'm
> >>
> >>really determined to
> >>
> >>>fix it. I'm sure it's not being cached by the
> >>
> >>browser or by a proxy.
> >>
> >>>Chopping and changing the locale in the browser
> >>
> >>proves that.
> >>
> >>>What also puzzles me is the work-around I did: I
> >>
> >>recreated the German
> >>
> >>>_de.properties file, and so now I have something
> >>
> >>sensible (the old
> >>
> >>>strings are pretty stupid random bits of text).
> >>
> >>But when I deleted this
> >>
> >>>new German file to test if the bug had gone, the
> >>
> >>old German strings
> >>
> >>>reappeared.
> >>>
> >>>What is my next logical step? I'm completely stuck
> >>
> >>here.
> >>
> >>>Thanks
> >>>Adam
> >>>
> >>
> >>
> >>-- 
> >>struts 1.1 + tomcat 5.0.16 + java 1.4.2
> >>Linux 2.4.20 Debian
> >>
> >>
> >>
> >
> > ---------------------------------------------------------------------
> >
> >>To unsubscribe, e-mail:
> >>taglibs-user-unsubscribe@jakarta.apache.org
> >>For additional commands, e-mail:
> >>taglibs-user-help@jakarta.apache.org
> >>
> >
> >
> >
> > __________________________________
> > Do you Yahoo!?
> > Yahoo! Hotjobs: Enter the "Signing Bonus" Sweepstakes
> > http://hotjobs.sweepstakes.yahoo.com/signingbonus
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: taglibs-user-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail: taglibs-user-help@jakarta.apache.org
> >
> >
>
>
> -- 
> struts 1.1 + tomcat 5.0.16 + java 1.4.2
> Linux 2.4.20 Debian
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: taglibs-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: taglibs-user-help@jakarta.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: taglibs-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: taglibs-user-help@jakarta.apache.org


Mime
View raw message