tomcat-taglibs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Evgeny Gesin <evgenyge...@yahoo.com>
Subject Re: ApplicationResources.properties apparently cached
Date Wed, 21 Jan 2004 10:54:05 GMT
I think somethings can be wrong with application or
understanding how it works with bundle.properties, if
DE still cached. Try to remove compiled pages (under
the "work" directory in Tomcat), stop and start Tomcat
and point browser to the same pages again and see what
happen.

Evgeny Gesin
Javadesk CEO / Founder


--- Adam Hardy <ahardy.struts@cyberspaceroad.com>
wrote:
> Can anybody make any comment about this? Other than
> that you think I 
> might be losing it?
> 
> Thanks
> 
> On 01/20/2004 06:38 PM Adam Hardy wrote:
> > I have set up my i18n properties files for use
> with the <fmt:message> 
> > taglib (jstl 1.0) via the
> javax.servlet.jsp.jstl.fmt.localizationContext 
> > and I tested it out with DE and EN to make sure my
> different locales on 
> > the browser would generate the correct language
> text.
> > 
> > All worked, and so I deleted the German file,
> since it was only a test 
> > and I'm not ready to do all the proper translation
> into German yet.
> > 
> > I deleted the _en.properties and _de.properties
> files, and have only a 
> > default ApplicationResources.properties so I
> really can't see where the 
> > old German strings are coming from.
> > 
> > However the German strings keep appearing in my
> web pages in German 
> > browsers.
> > 
> > This has been troubling me for a month now and I'm
> really determined to 
> > fix it. I'm sure it's not being cached by the
> browser or by a proxy. 
> > Chopping and changing the locale in the browser
> proves that.
> > 
> > What also puzzles me is the work-around I did: I
> recreated the German 
> > _de.properties file, and so now I have something
> sensible (the old 
> > strings are pretty stupid random bits of text).
> But when I deleted this 
> > new German file to test if the bug had gone, the
> old German strings 
> > reappeared.
> > 
> > What is my next logical step? I'm completely stuck
> here.
> > 
> > Thanks
> > Adam
> > 
> 
> 
> -- 
> struts 1.1 + tomcat 5.0.16 + java 1.4.2
> Linux 2.4.20 Debian
> 
> 
>
---------------------------------------------------------------------
> To unsubscribe, e-mail:
> taglibs-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail:
> taglibs-user-help@jakarta.apache.org
> 


__________________________________
Do you Yahoo!?
Yahoo! Hotjobs: Enter the "Signing Bonus" Sweepstakes
http://hotjobs.sweepstakes.yahoo.com/signingbonus

---------------------------------------------------------------------
To unsubscribe, e-mail: taglibs-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: taglibs-user-help@jakarta.apache.org


Mime
View raw message