tomcat-taglibs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ann Sunhachawee <ann.sunhacha...@sun.com>
Subject Re: using JSTL with Sun ONE App Server 7
Date Mon, 24 May 2004 22:36:19 GMT
Darrell -
JSTL 1.1 is supported on J2EE 1.4 compliant containers, and JSTL 1.0 is 
supported on J2EE 1.3 compliant containers, so i think you might be 
using JSTL1.1.
(you can check out the first paragraph here: 
http://jakarta.apache.org/taglibs/doc/standard-doc/intro.html) If you 
have further netbeans specific questions or feedback, please send it to 
nbusers@netbeans.org.

-Ann

Darrell Esau wrote:

>Hello all,
>
>Please excuse if this is a duplicate message --
>
>I'm quite new to JSTL ..
>I've been developing some JSP's using JSTL with NetBeans 3.6 (using the 
>internal Tomcat 5 server).
>
>I just tried deploying my app onto a Sun ONE App Server (version 7) and found 
>the following error:
>
>org.apache.jasper.compiler.CompileException: /jsp/SampleView.jsp(3,0) /jsp/fragments/stdstart.jspf(1,0)

>This absolute uri (http://java.sun.com/jsp/jstl/core) cannot be resolved in 
>either web.xml or the jar files deployed with this application.
>
>I then realized that my dev app server (tomcat5) is J2EE 1.4, where Sun ONE 
>App Server 7 is J2EE 1.3.
>
>How (if at all) can I use JSTL with Sun ONE App Server 7 (a J2EE 1.3 
>container)?
>
>I tried adding the standard.jar and the jstl.jar JAR files to the WEB-INF/lib 
>directory, but still no go.
>
>Advice?
>
>Thanks,
>d
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: taglibs-user-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: taglibs-user-help@jakarta.apache.org
>  
>


---------------------------------------------------------------------
To unsubscribe, e-mail: taglibs-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: taglibs-user-help@jakarta.apache.org


Mime
View raw message