tomcat-taglibs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Frank Burns" <frankbu...@the-hub.demon.co.uk>
Subject JSTL1.1 and DataSource problems
Date Tue, 08 Jun 2004 19:21:03 GMT
I'm using Tomcat 5.0.16.

I've just upgraded from jakarta-taglibs-standard-1.0.5 to
jakarta-taglibs-standard-1.1.0.

I have a JSP containing this JSTL:

<sql:query var="results" dataSource="${applicationScope.dataSource}">
 SELECT * FROM System WHERE Id=1
</sql:query>

where applicationScope.dataSource is a DataSource that I place in the
application scope via a listener.

This worked before my upgrade, but now I get this error:

[ServletException in:/sysAdminModule/banners/generalBanner.jsp] Unable to
get connection, DataSource invalid: "java.sql.SQLException: No suitable
driver"

Any ideas why this worked with JSTL1.0 and now, with JSTL1.1, it does not?

Thanks,

Frank.


---------------------------------------------------------------------
To unsubscribe, e-mail: taglibs-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: taglibs-user-help@jakarta.apache.org


Mime
View raw message