tomcat-taglibs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amroz Siddiqui <amrozka...@gmail.com>
Subject tag directory problem
Date Tue, 24 May 2005 10:03:47 GMT
Hello,
I am using Tomcat 5.0.
I created a simple JSP file.
##################  test.jsp
<html><head>
<%@ taglib prefix="my" tagdir="/WEB-INF/tags" %>
</head><body>
<my:mytag myvar="apple" />
</body>
</html>
###########
and another tag file
#################### mytag.tag
<%@ attribute name="myvar" %>
<h1>I got an ${myvar} </h1>
##############

when I store my test.jsp in webapps/ROOT
and mytag.tag in WEB-INF/tags 
directory, it works fine.
But when I store my test.jsp in another directory (esms-1.0) that is
for an application ( it is deployed fine) and my mytag.tag file in
WEB-INF/tags directory inside esms-1.0, it does not work.
The main problem is that the variable myvar does not get passed to the
tag file and is displayed in the browser as ${myvar}.
I looked in the generated Java Code for both of the tag files and I
got this difference at the place of the variable myvar :
in the first case:

out.write((java.lang.String)
org.apache.jasper.runtime.PageContextImpl.proprietaryEvaluate("${myvar}",java.lang.String.class,(PageContext)this.getJspContext(),null,false));

in the second case:
out.write("${myvar}");

Please help.

---------------------------------------------------------------------
To unsubscribe, e-mail: taglibs-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: taglibs-user-help@jakarta.apache.org


Mime
View raw message