tomcat-taglibs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rashmi Rubdi <dev_subscripti...@yahoo.com>
Subject Re: Content is not allowed in prolog. - text editor for Windows XP that shows special characters before the prolog
Date Sun, 23 Jul 2006 03:43:30 GMT
Sorry about this, i'm a newbie to jstl, and I'm trying this xml parsing with jstl for the first
time. The mismatch is due to the fact that I copied code from older articles on the Internet
dating back to 2002, 2003 
   
  I made corrections to make everything conform to JSTL1.1, also checked the version of the
actual .tld files and jstl.jar and standard.jar files , but I still get the error 
  SAXParseException: Content is not allowed in prolog.

  Is there anything else that could be wrong, that I need to check for?
   
  My new
  web.xml
      <taglib>
      <taglib-uri>http://java.sun.com/jsp/jstl/fmt</taglib-uri>
      <taglib-location>/WEB-INF/tld/fmt.tld</taglib-location>
    </taglib>
      <taglib>
      <taglib-uri>http://java.sun.com/jsp/jstl/core</taglib-uri>
      <taglib-location>/WEB-INF/tld/c.tld</taglib-location>
    </taglib>
      <taglib>
      <taglib-uri>http://java.sun.com/jsp/jstl/sql</taglib-uri>
      <taglib-location>/WEB-INF/tld/sql.tld</taglib-location>
    </taglib>
      <taglib>
      <taglib-uri>http://java.sun.com/jsp/jstl/xml</taglib-uri>
      <taglib-location>/WEB-INF/tld/x.tld</taglib-location>
    </taglib>
   
  Inside JSP:
<%@ taglib prefix="c" uri="http://java.sun.com/jsp/jstl/core" %>
<%@ taglib prefix="x" uri="http://java.sun.com/jsp/jstl/xml" %>

Hassan Schroeder <hassan@webtuitive.com> wrote:
  Rashmi Rubdi wrote:

> There might be something wrong on what I have in my web.xml , compared to what's in the
JSP
> 
> 
> http://java.sun.com/jstl/fmt
> /WEB-INF/tld/fmt.tld
> 
> 
> http://java.sun.com/jstl/core
> /WEB-INF/tld/c.tld
> 
> 
> http://java.sun.com/jstl/sql
> /WEB-INF/tld/sql.tld
> 
> 
> http://java.sun.com/jstl/x
> /WEB-INF/tld/x.tld
> 
> 
> JSP:
> 
> 
> 

This last line's URI doesn't match the rest.

You should be using JSTL 1.0 *or* 1.1, not mixing them :-)

-- 
Hassan Schroeder ----------------------------- hassan@webtuitive.com
Webtuitive Design === (+1) 408-938-0567 === http://webtuitive.com
opinion: webtuitive.blogspot.com

dream. code.



---------------------------------------------------------------------
To unsubscribe, e-mail: taglibs-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: taglibs-user-help@jakarta.apache.org



 		
---------------------------------
Do you Yahoo!?
 Get on board. You're invited to try the new Yahoo! Mail Beta.
Mime
  • Unnamed multipart/alternative (inline, 8-Bit, 0 bytes)
View raw message