tomcat-taglibs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Cooper" <mart...@apache.org>
Subject Re: Bug
Date Sat, 28 Apr 2007 19:04:56 GMT
On 4/28/07, Venu Madhav.Yelamanchili <vyelamanchili@miraclesoft.com> wrote:
>
> Rashmi Rubdi wrote:
> > Hi Venu,
> >
> > What version of JSTL are you using?
> >
> > This might be a configuration issue, according to the documentation
> here:
> >
> >
> http://jakarta.apache.org/taglibs/sandbox/doc/datagrid-doc/index.html#requirements
> >
> > "This custom tag library requires a servlet container that supports
> > the JavaServer Pages Specification, version 1.2 or higher. It also
> > requires the Jakarta JSTL Tag Libraries 1.0 and the Common Math
> > Library 1.0."
> >
> > -Regards
> > Rashmi
> >
> >
> > On 4/28/07, Venu Madhav.Yelamanchili <vyelamanchili@miraclesoft.com>
> > wrote:
> >>  Hi,
> >>  I tried to use the datagrid tags provided by apache. I found a code
> >> segment
> >> like ui:dataGrid items="${alist}". But this is not working for me.
> >> bcoz the
> >> items attribute in gridtaglib is not accepting runtime expressions.
> >> please
> >> provide the correct usage of your grid taglibs. ?
> >>
> >> --
> >> Regards,
> >>
> >> Venu madhav.Yelamanchili
> >>
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: taglibs-user-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail: taglibs-user-help@jakarta.apache.org
> >
> >
> Hi,
>              Am using every thing according to specifications. After
> opening link below
>
> http://jakarta.apache.org/taglibs/sandbox/doc/datagrid-doc/index.html#requirements
>
> go to TagReference. There in the first row it was given as attribute
> items wont support  RunTime ExpressionEvaluation. But in the example
> below that  table  it was given as
>
> |<ui:dataGrid *items="${employees}"* var="employee" name="datagrid1"
> cellPadding="0" cellSpacing="0">
> How is it possible. when i copied the same copied into my editor and
> executed . I got an error which states that the attribute ITEM will not
> accept
> expressions.
> |


*item* or *items*? What is the *exact* error message, and what is the
*exact* syntax you are using?

The "Runtime Expression Evaluation" column in the documentation refers to
JSP scripting expressions, not the expression language you are using.

If you're not already using JSP 2.x, I would recommending doing so and
ensuring that your web.xml file is referencing Servlets 2.4 and not an
earlier version.

--
Martin Cooper


--
> Regards,
>
> Venu madhav.Yelamanchili
>
> Software Trainee
>
> Miracle Software Systems
>
> Email: vyelamanchili@miraclesoft.com
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: taglibs-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: taglibs-user-help@jakarta.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message