tomee-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Charles Moulliard (Resolved) (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (OPENEJB-1725) NPE - can't start OpenEJB services
Date Wed, 21 Dec 2011 13:59:30 GMT

     [ https://issues.apache.org/jira/browse/OPENEJB-1725?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Charles Moulliard resolved OPENEJB-1725.
----------------------------------------

    Resolution: Fixed

We have this error on karaf when openejb-server is not installed for openeejb-osgi
                
> NPE - can't start OpenEJB services
> ----------------------------------
>
>                 Key: OPENEJB-1725
>                 URL: https://issues.apache.org/jira/browse/OPENEJB-1725
>             Project: OpenEJB
>          Issue Type: Bug
>          Components: osgi
>            Reporter: Charles Moulliard
>
> 2011-12-21 14:49:32,539 | WARN  | FelixStartLevel  | Activator                      
 | openejb.core.osgi.impl.Activator   73 | 119 - org.apache.openejb.core-osgi - 4.0.0.beta-2-SNAPSHOT
| can't find service manager
> 2011-12-21 14:49:32,540 | WARN  | FelixStartLevel  | Activator                      
 | openejb.core.osgi.impl.Activator  114 | 119 - org.apache.openejb.core-osgi - 4.0.0.beta-2-SNAPSHOT
| can't invoke method init since the service manager is null
> 2011-12-21 14:49:32,541 | ERROR | FelixStartLevel  | Activator                      
 | openejb.core.osgi.impl.Activator   81 | 119 - org.apache.openejb.core-osgi - 4.0.0.beta-2-SNAPSHOT
| can't start OpenEJB services
> java.lang.NullPointerException
> 	at org.apache.openejb.core.osgi.impl.Activator.invoke(Activator.java:117)[119:org.apache.openejb.core-osgi:4.0.0.beta-2-SNAPSHOT]
> 	at org.apache.openejb.core.osgi.impl.Activator.start(Activator.java:76)[119:org.apache.openejb.core-osgi:4.0.0.beta-2-SNAPSHOT]
> 	at org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:629)[org.apache.felix.framework-3.0.9.jar:]
> 	at org.apache.felix.framework.Felix.activateBundle(Felix.java:1842)[org.apache.felix.framework-3.0.9.jar:]
> 	at org.apache.felix.framework.Felix.startBundle(Felix.java:1759)[org.apache.felix.framework-3.0.9.jar:]
> 	at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1163)[org.apache.felix.framework-3.0.9.jar:]
> 	at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)[org.apache.felix.framework-3.0.9.jar:]
> 	at java.lang.Thread.run(Thread.java:680)[:1.6.0_29]

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message