tomee-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Romain Manni-Bucau (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TOMEE-1460) deploying cxf webservice in host other than localhost
Date Mon, 01 Dec 2014 08:49:13 GMT

    [ https://issues.apache.org/jira/browse/TOMEE-1460?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14229548#comment-14229548
] 

Romain Manni-Bucau commented on TOMEE-1460:
-------------------------------------------

Why do you say it uses localhost? Did you hit it on test.com? I said you earlier I think that
logs just take one of the hosts (didnt fixed logs with this task). Also we didn't change our
binding so issue is somewhere else. Can be tomee.jaxws.oldsubcontext or tomee.jaxws.subcontext
properties.



> deploying cxf webservice in host other than localhost
> -----------------------------------------------------
>
>                 Key: TOMEE-1460
>                 URL: https://issues.apache.org/jira/browse/TOMEE-1460
>             Project: TomEE
>          Issue Type: Bug
>    Affects Versions: 1.7.1, 1.7.2
>            Reporter: Matthew Broadhead
>            Assignee: Romain Manni-Bucau
>             Fix For: 2.0.0-Milestone-1, 1.7.2
>
>
> i have a basic test webservice with interface TestWs
> {code}
>     package testws;
>     import javax.jws.WebService;
>     @WebService(targetNamespace = "http://test.com/testws/webservices/test")
>     public interface TestWs {
>         void test();
>     }
> {code}
> and class Test
> {code}
>     package testws;
>     import javax.ejb.Stateless;
>     import javax.jws.WebService;
>     @Stateless
>     @WebService(portName = "TestPort", serviceName = "TestService", targetNamespace =
"http://test.com/testws/webservices/test", endpointInterface = "testws.TestWs")
>     public class Test implements TestWs {
>         @Override
>         public void test() {
>         }
>     }
> {code}
> in server.xml i have two host elements
> {code:xml}
>     <Host name="localhost">
>     <Host name="test.com">
> {code}
> deploying the war to localhost everything is fine.  deploying to test.com it does not
work.  the log reads:
> {code}
>     INFO: Webservice(wsdl=http://localhost:8080/testws/Test, qname={http://test.com/testws/webservices/test}TestService)
--> Ejb(id=Test)
> {code}
> whereas the expected result might be
> {code}
>     INFO: Webservice(wsdl=http://test.com:8080/testws/Test, qname={http://test.com/testws/webservices/test}TestService)
--> Ejb(id=Test)
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message