tomee-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Romain Manni-Bucau (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TOMEE-1477) TomEE wont start if added maven-properties to <args>
Date Mon, 15 Dec 2014 14:33:13 GMT

    [ https://issues.apache.org/jira/browse/TOMEE-1477?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14246682#comment-14246682
] 

Romain Manni-Bucau commented on TOMEE-1477:
-------------------------------------------

should work if you keep a " " inside. basicall args should ATM be space delimited and is here
for -X properties more than system properties (using them here works  more as a side effect
than a feature since they were designed to be in systemVariables or src/main/tomee/conf/system.properties)

> TomEE wont start if added maven-properties to <args>
> ----------------------------------------------------
>
>                 Key: TOMEE-1477
>                 URL: https://issues.apache.org/jira/browse/TOMEE-1477
>             Project: TomEE
>          Issue Type: Bug
>          Components: TomEE Maven Plugin
>    Affects Versions: 1.7.1
>         Environment: Mac, osX
>            Reporter: Reinhard Sandtner
>            Priority: Minor
>
> if you have something like
> {code}
> <properties>
>     <tomee.additional.args />
>     <tomee.additional.ldap.args />
> </properties>
> <profiles>
>     <profile>
>         <id>tomee</id>
>         <properties>
>             <tomee.additional.ldap.args>-DldapPrinicpal=principal -DldapPassword=pass
-DldapUrl=ldap://myurl:389</tomee.additional.ldap.args>
>         </properties>
>     </profile>
> </profiles>
> ...
> <plugin>
>     <groupId>org.apache.openejb.maven</groupId>
>     <artifactId>tomee-maven-plugin</artifactId>
>     <version>${tomee.mavenplugin.version}</version>
>         <configuration>
>             <tomeeVersion>${tomee.version}</tomeeVersion>
>             <tomeeClassifier>${tomee.classifier}</tomeeClassifier>
>             <args>-Dopenejb.log.factory=log4j ${tomee.additional.args} ${tomee.additional.ldap.args}
${tomee.wps.additional.args}</args>
> ...
> {code}
> tomEE startup fails with message: can not find main class (my local message: Hauptklasse
konnte nicht gefunden werden)
> the problem is that the first maven property is empty and will be passed as an emtpy
String.
> this behavoir only occurs on my mac (and i think this issue will be on linux to). everything
works fine on my windows-box.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message