tomee-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Reinhard Sandtner (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (TOMEE-1477) TomEE wont start if added maven-properties to <args>
Date Mon, 15 Dec 2014 14:37:14 GMT

     [ https://issues.apache.org/jira/browse/TOMEE-1477?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Reinhard Sandtner updated TOMEE-1477:
-------------------------------------
    Attachment: TOMEE-1477.patch

not sure if i hit the right place - maybe it would be better filter in maven-plugin

> TomEE wont start if added maven-properties to <args>
> ----------------------------------------------------
>
>                 Key: TOMEE-1477
>                 URL: https://issues.apache.org/jira/browse/TOMEE-1477
>             Project: TomEE
>          Issue Type: Bug
>          Components: TomEE Maven Plugin
>    Affects Versions: 1.7.1
>         Environment: Mac, osX
>            Reporter: Reinhard Sandtner
>            Priority: Minor
>         Attachments: TOMEE-1477.patch
>
>
> if you have something like
> {code}
> <properties>
>     <tomee.additional.args />
>     <tomee.additional.ldap.args />
> </properties>
> <profiles>
>     <profile>
>         <id>tomee</id>
>         <properties>
>             <tomee.additional.ldap.args>-DldapPrinicpal=principal -DldapPassword=pass
-DldapUrl=ldap://myurl:389</tomee.additional.ldap.args>
>         </properties>
>     </profile>
> </profiles>
> ...
> <plugin>
>     <groupId>org.apache.openejb.maven</groupId>
>     <artifactId>tomee-maven-plugin</artifactId>
>     <version>${tomee.mavenplugin.version}</version>
>         <configuration>
>             <tomeeVersion>${tomee.version}</tomeeVersion>
>             <tomeeClassifier>${tomee.classifier}</tomeeClassifier>
>             <args>-Dopenejb.log.factory=log4j ${tomee.additional.args} ${tomee.additional.ldap.args}
${tomee.wps.additional.args}</args>
> ...
> {code}
> tomEE startup fails with message: can not find main class (my local message: Hauptklasse
konnte nicht gefunden werden)
> the problem is that the first maven property is empty and will be passed as an emtpy
String.
> this behavoir only occurs on my mac (and i think this issue will be on linux to). everything
works fine on my windows-box.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message