tomee-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Struberg (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TOMEE-1524) tomee doesn't start up deployments on restart
Date Sat, 14 Mar 2015 20:43:38 GMT

    [ https://issues.apache.org/jira/browse/TOMEE-1524?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14362017#comment-14362017
] 

Mark Struberg commented on TOMEE-1524:
--------------------------------------

I still think it should be on by default.

What is the issue with clusters? They also need to auto-restart the server anyway. Even in
a cluster. 
What I miss (maybe it exists and I just don't know) is a way to deploy _without_ start. That
should actually be the default. Plus own commands to start and stop the application. That
way you can easily do ripple-starts in cluster envs, cloud deployment, etc.

> tomee doesn't start up deployments on restart
> ---------------------------------------------
>
>                 Key: TOMEE-1524
>                 URL: https://issues.apache.org/jira/browse/TOMEE-1524
>             Project: TomEE
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>            Reporter: Mark Struberg
>             Fix For: 2.0.0
>
>
> We should set
> {quote}
> openejb.deployer.save-deployments = true
> {quote}
> in conf/system.properties as a default.
> This is needed for EAR deployments not getting 'lost' during server restarts.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message