tomee-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Felipe Jaekel (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TOMEE-1634) Problem wih context name not unique
Date Thu, 29 Oct 2015 10:45:27 GMT

    [ https://issues.apache.org/jira/browse/TOMEE-1634?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14980240#comment-14980240
] 

Felipe Jaekel commented on TOMEE-1634:
--------------------------------------

Problem was caused by OnmiFaces 2.1.

I didn't suspected of it initially because although there was an exception in localhost.log,
the webapp was starting and the parts I use from OmniFaces were working.

After I saw this message on the user list(http://goo.gl/1HFDe6), I changed it to version 1.11
and things are back to normal.

> Problem wih context name not unique
> -----------------------------------
>
>                 Key: TOMEE-1634
>                 URL: https://issues.apache.org/jira/browse/TOMEE-1634
>             Project: TomEE
>          Issue Type: Bug
>          Components: TomEE Core Server
>    Affects Versions: 1.7.2
>            Reporter: Felipe Jaekel
>         Attachments: fail.log, success.log
>
>
> Hi,
> I have this config in system.properties:
> openejb.deploymentId.format = {ejbJarId}/{ejbName}
> openejb.jndiname.format = {deploymentId}{interfaceType.annotationName}
> I'm using parallel deployment with TomEE 1.7.2 for some months without problem, but since
some weeks ago, sometimes I get an exception when I try to deploy a newer version, telling
that the context name is not unique. But if after some minutes I try to deploy the same webapp
with a different version it works.
> I also noticed that the extra unversioned context I mentioned on issue 1412 is not appearing
on tomcat manager anymore. https://issues.apache.org/jira/browse/TOMEE-1412
> I'm having a hard time to figure this out. I thought it could be related to some changes
I made on context.xml and pom.xml, but I reverted them and the problem still happens.
> I'll attach the server logs of a deployment that failed and one that succeeded. 
> Any help is welcome,
> Thanks



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message