tomee-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Salter (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (TOMEE-1977) MDB not listening to ActiveMQ messages
Date Mon, 01 Jul 2019 15:37:00 GMT

     [ https://issues.apache.org/jira/browse/TOMEE-1977?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

David Salter resolved TOMEE-1977.
---------------------------------
    Resolution: Not A Problem

Resolving this issue and marking as not a problem as resolution was provided by Dev Null 52.

> MDB not listening to ActiveMQ messages
> --------------------------------------
>
>                 Key: TOMEE-1977
>                 URL: https://issues.apache.org/jira/browse/TOMEE-1977
>             Project: TomEE
>          Issue Type: Documentation
>          Components: TomEE Core Server
>    Affects Versions: 7.0.2
>         Environment: Mac OS Sierra, 
>            Reporter: Dev Null 52
>            Priority: Trivial
>
> I have been trying for couple of days to have a trivial MDB example working to listen
on ActiveMQ Queue on default port. I am using TomEE 7.0.2.
> I tried first using an embedded Active MQ 5.2.0 broker, then moved it as a stand alone
process using activemq-maven-plugin plugin to rule out Active MQ out as a variable.I tried
MDB with annotation using activation config, without annotation but no avail. Examples online
vary and none of them appear to work. I am able to send to the Queue using a seperate Servlet
and able to validate then but not able to read.
> Also I am seeing very strange Auto-linking resource-ref logs whereby I see injections
for Beans that do not have those instances/types defined -- so very confused.
> Plain JMS and EJB worked like a charm on JEE. Using Maven
> META-INF/beans.xml ( empty )
> META-INF/ejb-jar.xml ( MDB and basic EJB descriptor )
> WEB-INF/resources.xml (ConnectionFactory and Queue definition pointing to localhost ActiveMQ
on default port ).
> WEB-INF/web.xml ( empty )
> Please help if possible.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message