tomee-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Schaft (Jira)" <j...@apache.org>
Subject [jira] [Commented] (TOMEE-2655) Depends on vulnerable Jackson Version
Date Tue, 03 Sep 2019 13:36:00 GMT

    [ https://issues.apache.org/jira/browse/TOMEE-2655?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16921430#comment-16921430
] 

Robert Schaft commented on TOMEE-2655:
--------------------------------------

Yeah, it would.

But I have zero experience with pull requests and no development or test environment.

> Depends on vulnerable Jackson Version
> -------------------------------------
>
>                 Key: TOMEE-2655
>                 URL: https://issues.apache.org/jira/browse/TOMEE-2655
>             Project: TomEE
>          Issue Type: Bug
>    Affects Versions: 7.1.1, 8.0.0-M3
>            Reporter: Robert Schaft
>            Priority: Critical
>              Labels: easyfix, security
>
> TomEE 7.1.1 depends on jackson-databind 2.9.6
> TomEE 8.0.0-M3 ships an even older version 2.9.4.
> All jackson versions up to 2.9.9.1 are vulnerable. Vulnerabilities in this component
are hard to mitigate, because it is likly that it parses network data.
> This issue currently blocks my company from using TomEE out of the box.



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

Mime
View raw message