tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Blevins <david.blev...@visi.com>
Subject Re: JNDI lookup help
Date Mon, 12 Nov 2007 02:44:15 GMT

On Nov 9, 2007, at 2:47 PM, Casey Rayman wrote:

> This fixed the error.  One hopefully last question for a while:  The  
> bean get's deployed, but it is still being deployed by the  
> {deploymentId}{interfaceType.annotationName} format.  Do I need to  
> force openejb.jndiname.format to something other than the default so  
> it takes the value from the weblogic config file?

Nope, the new per/ejb jndi name feature wasn't getting picked up quite  
right.  Added some better unit tests and fixed it up.  This should do  
the trick:

http://people.apache.org/~dblevins/openejb-594005

-David

>
>
> Casey
>
> On Nov 9, 2007, at 4:09 PM, David Blevins wrote:
>
>>
>> On Nov 9, 2007, at 1:01 PM, Casey Rayman wrote:
>>
>>> Unfortunately my Weblogic experience is clearly boxed in at  
>>> version 7, and I wouldn't say that my experience runs real deep  
>>> there either.  I've only been tinkering with this application a  
>>> few months now.
>>
>> No worries.  I think i've figured it out.  From the docs seems like  
>> reference-descriptor was the only deprecated and removed element.   
>> It also seems like it was just a wrapper element for the various  
>> resource-description, resource-env-description, ejb-reference- 
>> description, etc which are still there -- just no containing  
>> 'reference-descriptor' tag.
>>
>> So I've added all the necessary bits and it should work now:
>>
>> http://people.apache.org/~dblevins/openejb-593658/
>>
>> Give the above binary a try and let's cross our fingers :)  Let me  
>> know how it goes.
>>
>> -David
>>
>
>


Mime
View raw message