tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Blevins <david.blev...@visi.com>
Subject Re: Help for configuring openejb
Date Mon, 24 Dec 2007 06:34:09 GMT
Hi Joe,

The config looks ok at first glance.  Can you send a full stack trace  
of the NullPointerException?

-David


On Dec 23, 2007, at 9:29 PM, xianzheng wrote:

>
> Hi,
> I'm a new openejb user, or even a new starter of J2EE.
> I'm currently trying to configure the openejb to but encountered  
> unexpected
> NullPointerException.
> My configure file is as below:
> <?xml version="1.0" encoding="UTF-8"?>
> <openejb>
>
> 	<Container id="cmp" ctype="CMP_ENTITY">
> 		ConnectorName db
> 		PoolSize 10
> 	</Container>
>
> 	<Container id="stateful" ctype="STATEFUL">
> 		Passivator   org.apache.openejb.core.stateful.SimplePassivater
> 		TimeOut 20
> 		PoolSize 50
> 		BulkPassivate  50
> 	</Container>
>
> 	<Container id="stateless" ctype="STATELESS">
> 		TimeOut 0
> 		PoolSize 10
> 		StrictPooling true
> 	</Container>
>
> 	<Container id="mdb" ctype="MESSAGE">
> 		ResourceAdapter mq
> 		ActivationSpecClass org.apache.activemq.ra.ActiveMQActivationSpec
> 		InstanceLimit 5
> 	</Container>
>
> 	<Connector id="db" type="DataSource">
> 		JdbcDriver   org.postgresql.Driver
> 		JdbcUrl      jdbc:postgresql://localhost/zhou
> 		UserName     joe
> 		Password     xianzheng
> 	</Connector>
>
> 	<Resource id="mq">
> 		BrokerXmlConfig broker:(tcp://localhost:61616)?useJmx=false
>
> 		ServerUrl vm://localhost?async=true
> 	</Resource>
>
> 	<Connector id="mq_connector">
>    ResourceAdapter mq
> 	</Connector>
> 	
> 	<Deployments dir="apps/" />
>
> </openejb>
>
> I suspect it is caused by the db connector. How may I fix this please?
> Thanks for your time in advance.
>
> Regards,
>
> Joe
> -- 
> View this message in context: http://www.nabble.com/Help-for-configuring-openejb-tp14484775p14484775.html
> Sent from the OpenEJB User mailing list archive at Nabble.com.
>
>


Mime
View raw message