tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From White-Gandalf <Harry.Bo...@t-online.de>
Subject Installation: ClassNotFoundException: org.apache.openejb.loader.OpenEJBListener
Date Fri, 01 Feb 2008 06:34:39 GMT

Hi folks,

i'm new on Tomcat and OpenEJB. I had installed Tomcat 6.0.14 with some
problems, but nevertheless functioning at last. Now, i wanted to add
OpenEJB. After starting the installation procedure by copying the "war" to
webapps, when i tried to restart the server, it wasn't starting anymore. In
"stderr_...log" are "ClassNotFoundException:
org.apache.openejb.loader.OpenEJBListener" to be found.

Has anybody an idea, what's going wrong?

So far i had only followed the really simple copy operation, and i have one
speciality that possibly has something to do with that behavior.

After the installation of the "war" by tomcat, the batch file for starting
the server as a user application from the command line was changed. That
contradicts the fact, that tomcat has to be running as a service on my
system. To react on that, i executed the two lines in question by hand,
namely:

I executed by copying by hand:

copy /Y "%CATALINA_BASE%\webapps\openejb\tomcat\annotations-api.jar"
"%CATALINA_HOME%\lib\annotations-api.jar"

I executed by adding the environment variable to the tomcat user profile:

set
JAVA_OPTS="-javaagent:%CATALINA_BASE%\webapps\openejb\lib\openejb-javaagent-3.0-beta-1.jar"
%JAVA_OPTS%

(In both cases the environment variables expanded...)

Is that in any matter incompatible with the way of deployment for servers in
user-application-mode?
Or will there be some other thing wrong with that EJB?

Is there any way to keep the server running, when only a subordered module
doesn't start correctly? Or do i have to keep the OpenEJB-Package deleted
until this matter is solved?

-- 
View this message in context: http://www.nabble.com/Installation%3A-ClassNotFoundException%3A-org.apache.openejb.loader.OpenEJBListener-tp15221444p15221444.html
Sent from the OpenEJB User mailing list archive at Nabble.com.


Mime
View raw message