tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Krell" <james.kr...@gmail.com>
Subject OpenEJB Version 3.0 beta 2 fails to initialize during deployment
Date Sun, 17 Feb 2008 20:40:30 GMT
OpenEJB Version 3.0 beta 2 (md5  238b1cc8b3903132e87544af760eeda5 ) fails to
initialize during deployment

Apache Tomcat/5.5.25

Sun Microsystems Inc. Java Version 1.5.0_14-b03

Operating System Microsoft Windows XP Professional

Version 5.1.2600 Service Pack 2 Build 2600



>From tomcat log prior to opening HTTP Connector port



INFO Thread-1 org.apache.catalina.startup.HostConfig - Deploying web
application archive *openejb.war*

ERROR Thread-1 org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/openejb]
- StandardWrapper.Throwable

java.lang.NoClassDefFoundError: org/apache/catalina/LifecycleListener

                at java.lang.Class.getDeclaredConstructors0(Native Method)

                at java.lang.Class.privateGetDeclaredConstructors(Unknown
Source)

                at java.lang.Class.getConstructor0(Unknown Source)

                at java.lang.Class.newInstance0(Unknown Source)

                at java.lang.Class.newInstance(Unknown Source)

                at org.apache.openejb.loader.LoaderServlet.init(
LoaderServlet.java:65)



Note:



No <listener> element present in web.xml

No <Listener> element present in server.xml



All other Tomcat 5.5.25 applications function flawlessly in my environment.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message