tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Blevins <david.blev...@visi.com>
Subject Re: Tomcat webapp Configuration
Date Sun, 04 May 2008 18:31:18 GMT

> On May 3, 2008, at 12:41 PM, JimOR wrote:
>
>>> 1)I would prefer to deploy my driver and openejb configuration in my
>>> ejb jar
>>
>> As noted in the other email, we can add support for that.
>
> Sorry, didn't think my first post went through... Just a preference,  
> not a
> show stopper...

No problem.  Gave a quick answer again primarily for the archives.

>
>>> 2)When my war contains jsf and/or IceFaces, openejb throws the
>>> following(edited for brevity):
>>> ERROR - Unable to process annotation in /jsfWebapp: Exception:
>>> Unable to
>>> load servlet class: javax.faces.webapp.FacesServlet:
>>> javax.faces.webapp.FacesServlet
>>> org.apache.openejb.OpenEJBException: Unable to load servlet class:
>>> javax.faces.webapp.FacesServlet: javax.faces.webapp.FacesServlet
>>> 	at
>>> org.apache.openejb.config.AnnotationDeployer
>>> $ProcessAnnotatedBeans.deploy(AnnotationDeployer.java:557)
>>> 	at
>>> org
>>> .apache
>>> .openejb.config.AnnotationDeployer.deploy(AnnotationDeployer.java: 
>>> 181)
>
>> This one is a puzzler.  I wonder if there's a class required by the
>> IceFaces impl of FacesServlet that isn't available.  I went to pull
>> down the source and check what it might be but it's one of those
>> register/agree to get the source kind of projects.  Do you know what
>> if any dependencies IceFaces has?
>
> IceFaces (jsf implementation only, no ajax enablement or facelets)  
> only
> requires a couple jars from the apache-commons family.   I'm trusting
> Eclipse/WTP/IceFaces plugin to manage the dependencies, but my  
> sample runs
> fine (instantiated the bean directly in the code) without OpenEJB
> installed.

If you can whip up a tiny example that reproduces the problem, I'll be  
happy to take a look at it.  You can attach the war to this jira: http://issues.apache.org/jira/browse/OPENEJB-797


> I also tried a jsf implementation I got from the Glassfish project a  
> few
> months back with the same result.  Checked for a download link to give
> you, but it's now called Majorra and I'd need to d'l and run it  
> before I'd
> have you chasing a red herring...
>
>> One technique you might try is to comment out the FacesServlet  
>> servlet
>> declaration from the web.xml and try loading the class in another
>> servlet. If it works/doesn't work that gives us some indication on
>> where the problem might be.
>
> JSF needs the url-mapping to work it's mojo before rendering the  
> response.
> I'm afraid that kind of filter-chain wiring is beyond me, and it'll  
> get
> more complicated when I add Facelets to the mix.  I did try  
> disabling the
> load-on-startup, but got the same result.

JSF in general is beyond me :)  Hopefully with the small sample war I  
can run through the startup code in Tomcat/OpenEJB with a debugger and  
hunt down the issue.

-David


Mime
View raw message