tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Louis MONTEIRO <jean-louis.monte...@atosorigin.com>
Subject Re: Active MQ 5.1 support
Date Tue, 16 Sep 2008 13:51:02 GMT

Hi David,

>From my point of view, it's not possible to switch from 4.1.x to 5.1.x
without any change in OpenEJB.
In the current openejb-core module, the OpenEjbBrokerFactory implements
BrokerFactory.BrokerFactoryHandler but in the ActiveMQ 5.1, this interface
is no more an internal class.
The new interface is org/apache/activemq/broker/BrokerFactoryHandler.java

Do you agree ?

Jean-Louis



David Blevins wrote:
> 
> 
> On Sep 15, 2008, at 3:45 PM, rde8026 wrote:
> 
>>
>> I'm using the standard lib form a zip file...
> 
> Ok.  In terms of general library upgrading, we generate two files  
> (dependencies.xml and dependencies.txt) that we put inside of every  
> openejb-*.jar that says what dependencies the jar has.  The data is  
> nested to show a tree view to make it easier to see what dependencies  
> are pulled in only by third party libraries.
> 
> Here is the top part of  dependencies.txt for openejb-core-3.1- 
> SNAPSHOT.jar:
> 
>    activemq-core-4.1.1.jar
>     activeio-core-3.0.0-incubator.jar
>     backport-util-concurrent-2.1.jar
>    activemq-ra-4.1.1.jar
>    asm-2.2.3.jar
>    asm-commons-2.2.3.jar
>     asm-tree-2.2.3.jar
>    asm-finder-3.1-SNAPSHOT.jar
>    commons-cli-1.1.jar
>    commons-collections-3.2.jar
>    .....
> 
> So you should only need to remove activemq-core-4.1.1.jar, activemq- 
> ra-4.1.1.jar and any libraries they depend on, which are activeio- 
> core-3.0.0-incubator.jar and backport-util-concurrent-2.1.jar.  As far  
> as replacing them, you'll definitely need activemq-core-5.1.0.jar and  
> activemq-ra-5.1.0.jar.
> 
>   
> http://people.apache.org/repo/m2-ibiblio-rsync-repository/org/apache/activemq/activemq-core/5.1.0/activemq-core-5.1.0.jar
>   
> http://people.apache.org/repo/m2-ibiblio-rsync-repository/org/apache/activemq/activemq-ra/5.1.0/activemq-ra-5.1.0.jar
> 
> .. plus their non-optional depenencies.  The activemq-core-5.1.0.pom  
> shows these required deps (versions are in activemq-parent-5.1.0.pom).
> 
>   
> http://people.apache.org/repo/m2-ibiblio-rsync-repository/org/apache/activemq/activeio-core/3.1.0/activeio-core-3.1.0.jar
>   
> http://people.apache.org/repo/m2-ibiblio-rsync-repository/org/apache/camel/camel-core/1.3.0/camel-core-1.3.0.jar
> 
> The activeio-core pom lists backport-util-concurrent as a dependency,  
> but I couldn't find any use of it in their source.  I'd try getting by  
> without it.
> 
> Definitely let us know how it goes.
> 
> -David
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Active-MQ-5.1-support-tp19400471p19512302.html
Sent from the OpenEJB User mailing list archive at Nabble.com.


Mime
View raw message