tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Gallimore <jonathan.gallim...@gmail.com>
Subject Re: ClassNotFoundException when deploying openejb.war
Date Fri, 13 Feb 2009 12:25:13 GMT
Its sounds like a bug and I would imagine we can fix it - can you open a 
JIRA issue for it(https://issues.apache.org/jira/browse/OPENEJB)? I'm 
away this weekend, but could look at a fix next week (unless someone 
else beats me to it).

Jon


Alberto López wrote:
> Hi again David,
>
> I didn't install tomcat as a service, I simply unzipped it. 
>
> I also experimented with the different path and the results are really
> weird. But I thing I finally figured it out.
>
> As I told in a previous message, after having these problems I installed
> Tomcat 6.0.18 in another location and it worked which made me think that
> perhaps the path had something to say.
>
> So what I did was to install Tomcat (always unzipping) again in its old
> location and bingo: the same old problem.
>
> It was somewhat hard to believe that the path could be a reason, specially
> when the path that causes the problems has no spaces and the one which works
> fine does have some of them.
>
> This is the path with issues:
> C:\Desarrollo\Libs+Tools\Apache\Tomcat-6.0.18\webapps
>
> This one works fine: C:\Archivos de programa\Desarrollo\Tomcat-6.0.18
>
> Weird, isn't it? 
>
> So I made the final test: I remove the '+' character from the first path,
> since it is the only "strange" character. And it worked!
>
> Could it be perhaps that the '+' causes strange behaviours within a
> classpath? Seems something like that to me (could be perhaps an useful hint
> for including it in a FAQ).
>
> Regards,
>
> Alberto
>
>   


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message