tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Gallimore <jonathan.gallim...@gmail.com>
Subject Re: Web services deployment example?
Date Tue, 14 Apr 2009 19:31:48 GMT
I had hoped it might work, but I'm not surprised it didn't. I've always
found I need to create both interfaces and have the same methods in both.

I did try and setting the WS interface to extend the local one, and had the
same error as you. The other way round seemed to work, though. I also tried
having the two interfaces inherit a common interface, and that didn't work
either.

I remember thinking this was a pain when I hit it about a year ago - I'm
glad its not just me :)

As David says, we could probably make this work, but its against the current
spec, so the code might not work with other containers. I'm happy to have a
go at this when I have some free time (unless someone else beats me to it)
;-)

Cheers

Jon

On Tue, Apr 14, 2009 at 8:05 PM, Laird Nelson <ljnelson@gmail.com> wrote:

> On Tue, Apr 14, 2009 at 2:02 PM, Laird Nelson <ljnelson@gmail.com> wrote:
>
> > On Tue, Apr 14, 2009 at 1:44 PM, Jonathan Gallimore <
> > jonathan.gallimore@gmail.com> wrote:
> >
> >> If think you're right - the bean didn't get added to JNDI on my machine.
> >> I've added a local interface and a test to verfiy the sample bean works
> >> through the EJB interface too.
> >>
> >
> > But if David is right, then it shouldn't, right?
> >
>
> OK, just picked up your test and the changes in the trunk.
>
> I see that your implementation bean (CalculatorImpl) implements two
> interfaces, the CalculatorWs and CalculatorLocal ones, which are simply
> copies of each other and have no other relationship.
>
> Just for kicks, I made CalculatorWs extend CalculatorLocal, and made no
> other changes.  The test fails.  Would you expect this failure?
>
> Best,
> Laird
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message