tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philipp Bunge <b...@crimson.ch>
Subject Re: Configuring Resource Adapter
Date Mon, 30 Nov 2009 10:18:07 GMT
Hi Tom

> I am also trying to use Jackrabbit via JCA.  I've placed the Jackrabbit RAR
> in the classpath and hard-coded some config-property-value in the
> META-INF/ra.xml file.  However, it's still not getting injected to my EJBs.
> I tried
>
> @Resource
> Repository repository;
>
> ... but this is null.

I had that issue as well, but the problem was actually unrelated to
any JNDI issues. I had forgotten to create the Jackrabbit repository
directory and that's why the resource adapter wasn't working. Took me
a while to figure out though, as the errors didn't show up in my logs.
I only noticed once I stepped through with a debugger.

I also set the connector ID as Christian wrote, but more out of
cosmetic reasons. It didn't actually have an effect on the deployment
in my case.

Cheers,
Philipp

Mime
View raw message