tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Blevins <david.blev...@visi.com>
Subject Re: Odd OpenEJB Remote Connection Behaviour
Date Wed, 18 Nov 2009 23:28:59 GMT
Going to move this one to the Geronimo dev list.

On Nov 16, 2009, at 1:14 AM, Quintin Beukes wrote:

> Hey,
>
> I have noticed something odd, not sure what is causing this.
>
> When I have a client on machine A connecting to a remote OpenEJB
> server on machine B everything works well. If I take the exact same
> setup but I have another server running on machine A as well (so there
> is a client+server  on machineA and a server on machineB), OpenEJB
> successfully authenticated against machine B but then immediately
> switches over all it's following connections to it's own machine (ie.
> localhost).
>
> I've noticed if there is no server on machineA with the client, then I
> receive the following error on stdout:
>
> WARNING [OpenEJB.client]: Failover: Cannot connect to server(s):
> ejbd://0.0.0.0:4201 Exception: Cannot connect to server
> 'ejbd://0.0.0.0:4201'.  Check that the server is started and that the
> specified serverURL is correct..  Trying next.
>
> When the server is running, then this doesn't happen. I first noticed
> this as follows:
> 1. I created a user on serverB
> 2. Authenticated the client against it which worked, so it obviously
> connected to the server
> 3. Started capturing data. The client was showing the data is there,
> but the server's database doesn't reflect it.
> 4. When I did a netstat I noticed a localhost :4201 connection.
> 5. I removed ALL users from the local machine, but it kept  
> authenticating.
> 6. So I restarted the client and did a netstat, there was both a
> localhost and 10.0.0.200 :4201 connection. The latter being in
> TIME_WAIT.
> 7. Whenever I stop the server on the local machine all works well as  
> intended.
>
> Quintin Beukes
>


Mime
View raw message