tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Blevins <david.blev...@visi.com>
Subject Re: Build failure in OpenEJB3
Date Thu, 10 Dec 2009 22:42:30 GMT

On Dec 2, 2009, at 8:11 PM, Sajith H Kariyawasam wrote:

> Hi all,
>
> I tried to download OpenEJB code and build, But got the following  
> build failure when i tried to execute
>
>     mvn -o -Dmaven.{test,itest}.skip -Dassemble clean install
>
> from Ubuntu.
>
> Could you please help me to figure this out ?
>
> Thanks
> Regards
> shk
>
> [WARNING] Warning in manifest for org.apache.openejb:openejb- 
> core:jar:3.1.3-SNAPSHOT : Did not find matching referal for  
> org.quartz.*
> [INFO] [antrun:run {execution: default}]
> [INFO] Executing tasks
>     [java] Could not find org.apache.openejb.util.MakeTxLookup. Make  
> sure you have it in your classpath
>     [java]     at  
> org.apache.tools.ant.taskdefs.ExecuteJava.execute(ExecuteJava.java: 
> 170)
>     [java]     at org.apache.tools.ant.taskdefs.Java.run(Java.java: 
> 710)

Hi Sajith,

I just tried a clean build on FreeBSD and OSX with no issues.  I used  
an empty maven repo just to make sure I didn't have any state that  
might cause my builds to succeed where others might fail.  I'm not  
sure what might cause the issue you are seeing.

Here is the exact build command I used:

   mvn clean install -Dmaven.test.skip=true -Dmaven.repo.local=tmp

Here's my maven info for the FreeBSD build:

Maven version: 2.0.10
Java version: 1.6.0_07
OS name: "freebsd" version: "7.2-stable" arch: "amd64" Family: "unix"

Try running with a clean repo like I did and see if that doesn't  
help.  I've sometimes noticed that maven gets bad state in the local  
repo and I get strange build failures.  Not sure if that's what  
happened here, but it's worth a try.

-David



Mime
View raw message