tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Davidson" <stephen.david...@etcc.com>
Subject RE: Maven + Jetty: Unknown JNDI name prefix
Date Thu, 21 Jan 2010 00:57:31 GMT
Hi Jonathon.

 

Yes, separate WAR & EJB Modules.

 

When I tried the "mvn jetty:run-exploded" on your pom, I ran into the
"AntMain" issue;

java.lang.NoClassDefFoundError: org/apache/tools/ant/launch/AntMain

 

So, I added that dependency to your pom and reran.

 

I have attached an updated pom.xml, as well as the output from when I
ran it.  I also added (although left commented out for the moment)  the
section to get jetty to run as part of the build process.  If you DO
want to try that out, note that it will do the "jetty:run" goal rather
than the "jetty:run-exploded" goal to start.  (And yes, did check, and I
am getting the same output for both).

 

Thanks!

 

-Steve

 

 

________________________________

From: Jonathan Gallimore [mailto:jonathan.gallimore@gmail.com] 
Sent: Wednesday, January 20, 2010 3:53 PM
To: users@openejb.apache.org
Subject: Re: Maven + Jetty: Unknown JNDI name prefix

 

Hi Steve,

Just going to dig around with this a bit more, and see if I can
reproduce it. How is your project setup - do you have a separate Maven
module for your webapp and EJBs? 

I've setup a basic project, but I'm not getting as far as you - I've
attached it, can you point out what I'm missing?

Cheers

Jon



On Mon, Jan 18, 2010 at 6:33 PM, Stephen Davidson <
stephen.davidson@etcc.com> wrote:

Greetings.

If it helps at all, looks like Jetty 6.1.11 is the latest this works on,
and happily this version of Jetty does not hang during the Maven
Integration test phase (6.1.9 does!).  So, from Jetty 6.1.12 on, there
is definitely an issue with "Unknown JNDI name prefix", as well as
ClassNotFound if you specify OpenEJB as a dependency for the Jetty
plugin rather than a project dependency, but I am not sure that these
are OpenEJB issues.

One thing I did observe was that Jetty 6.1.22 was not loading child
dependencies when OpenEJB was declared in the plugin.

I have queried Jetty on this as well, but I am wondering if there was an
API change in Jetty 6.1.12 that might be affecting OpenEJb?


-Steve

-----Original Message-----
From: Stephen Davidson [mailto:stephen.davidson@etcc.com]

Sent: Friday, January 15, 2010 6:23 PM
To: users@openejb.apache.org
Subject: RE: Maven + Jetty: Unknown JNDI name prefix

Greetings.

Well, works for Jetty 6.1.9, but is broken on Jetty 6.1.22.
Unfortunately, Jetty 6.1.9 hangs on maven Integration tests, but 6.1.22
will run.  I am going to do some digging to see if I can figure out what
version of Jetty this broke on.

-Steve



 


Mime
View raw message