tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Blevins <david.blev...@visi.com>
Subject Re: Issue with hibernate versions?
Date Tue, 15 Jun 2010 22:37:43 GMT

On Jun 7, 2010, at 1:04 PM, Totsline, Greg wrote:

> Hi -
> 
> We recently upgraded from JBoss EAP 4.3 to Jboss EAP 5.0 and are now getting the following
exceptions when creating the InitialContext() for OpenEJB 3.1.2:
> 
> 1.      OpenEJBException: Creating application failed: classpath.ear: java.lang.SecurityException:
class "org.hibernate.MappingException"'s signer information does not match signer information
of other classes in the same package
> 2.      Java.lang.String cannot be cast to java.net.URL
> 
> JBoss EAP 5.0 bundles Hibernate Core 3.3.2 GA and Hibernate Entity Manager 3.4.0.
> 
> Are there any work arounds for these issues?

Was hoping maybe another user might have had some good advice.

Seems like there are two versions of hibernate in your classpath.

Only thing I can recommend is if you're using maven add the -X option and it will spit out
the full classpath it uses when running tests.

-David


Mime
View raw message