tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: change HSQL version in unit test
Date Fri, 05 Aug 2011 08:11:35 GMT
hi,

you can add an exclusion to your maven dependency and then simply import
your dependency.

- Romain

2011/8/5 f.joe <falchetto.joe@gmail.com>

> Hello everybody,
> I'm using openejb and hsql for unit testing my application.
> I build and test the code using Maven.
> In my pom.xml I point to openejb-core 3.1.4
>                <dependency>
>                        <groupId>org.apache.openejb</groupId>
>                        <artifactId>openejb-core</artifactId>
>                        <version>3.1.4</version>
>                        <type>jar</type>
>                        <scope>test</scope>
>                </dependency>
>
> As far as I know openejb-core depend on hsqldb.
> Unfortunately, this dependency import in my classpath hsqldb-1.8.0.7.jar.
> I'd like to override this version with the hsql 2.0 implementation.
> Is there any way to perform this switch?
> Thanks,
> j.
>
> --
> View this message in context:
> http://openejb.979440.n4.nabble.com/change-HSQL-version-in-unit-test-tp3720651p3720651.html
> Sent from the OpenEJB User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message