tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Katya Todorova <katya.k.todor...@gmail.com>
Subject Re: Openejb lite bundles
Date Fri, 03 Feb 2012 14:48:42 GMT
Hi Romain,

I tried openejb-core-osgi (4.0 beta 2) but I'm runnng it on Equinox
and openejb-core-osgi deployer doesn't find the bundleDump in Equinox
format (bundle location is not properly calculated).

As for the mandatory imports, I was wondering whether they are
considered mandatory because of known issues or by accident. Thank you
for the details about geronimo osgi metadata.

Kind regards,
Katya

On Fri, Feb 3, 2012 at 4:09 PM, Romain Manni-Bucau
<rmannibucau@gmail.com> wrote:
> HI,
>
> if i remember it is because geronimo osgi meta information are not correct
> so we need it.
>
> For info openejb-core is shaded in openejb-core-osgi so you should maybe
> use the second one and not openejb-core.
>
> - Romain
>
>
> 2012/2/3 Katya Todorova <katya.k.todorova@gmail.com>
>
>> Hi Jean-Louis,
>>
>> thank you for the hint, it helped a lot. I have another question
>> regarding openejb-core bundle-
>> It seems it strictly depends on org.apache.geronimo.connector,
>> org.apache.geronimo.osgi.locator and org.apache.geronimo.transaction.
>> Are these imports mandatory to openejb-core (from functional point of
>> view) ? I looked for example at connector usages and I think the
>> import could be made optional in OpenEJB lite case (same for
>> geronimo.transaction and osgi.locator). What do you think about that?
>>
>> Thanks a lot,
>> Katya
>>
>>
>>
>> On Tue, Jan 31, 2012 at 9:58 AM, Jean-Louis MONTEIRO <jeanouii@gmail.com>
>> wrote:
>> > Hi,
>> >
>> > we managed to set up some OSGi features making OpenEJB to work with
>> Apache
>> > Karaf.
>> > Could you have a look to our existing features and let us know if that is
>> > enough or not?
>> >
>> > May be, we'll have to change some import to make EclipseLink imports
>> > optional but there.
>> > Feel free to open a JIRA with a patch attached and we'll be more than
>> happy
>> > to commit it for you.
>> >
>> > Hope it helps.
>> > Jean-Louis
>> >
>> > 2012/1/30 Katya Todorova <katya.k.todorova@gmail.com>
>> >
>> >> Hi,
>> >>
>> >> I'm trying to integrate OpenEJB lite container with EclipseLink (in
>> >> Equinox).  I looked at openejb-lite-4.0.0-beta-1 bundle but it
>> >> contains OpenJPA packages I don't really need.
>> >> On the other hand, OpenEJB standalone server contains separate bundles
>> >> but there are too many in there. Could you please help me find out the
>> >> minimal set of dependencies enough for OpenEJB lite?
>> >>
>> >> Thank you in advance,
>> >> Katya
>> >>
>>

Mime
View raw message