tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Blevins <david.blev...@gmail.com>
Subject Re: Problem deploying REST Examples on Eclipse
Date Tue, 24 Apr 2012 09:40:34 GMT
Moving the libraries doesn't work with beta-2, but I did do some hacking on that just Saturday
for the coming 1.0.0 binaries.

Is it possible you can try this set of binaries?

  http://people.apache.org/~dblevins/staging-081/openejb-4.0.0/

Keep in mind those will likely not be the actual 1.0.0 binaries that are released, so when
TomEE 1.0.0 comes out make sure you download the official binaries.


-David

On Apr 24, 2012, at 2:12 AM, kalgik wrote:

> Hello everybody.
> I tried to deploy the "REST Example with Application" on Eclipse Indigo.
> Here the steps I followed:
> First of all,  I installed TomEEplus  
> http://www.apache.org/dyn/closer.cgi/openejb/4.0.0-beta-2/apache-tomee-1.0.0-beta-2-plus.zip
> http://www.apache.org/dyn/closer.cgi/openejb/4.0.0-beta-2/apache-tomee-1.0.0-beta-2-plus.zip

> . I moved all the jar files from webapps\tomee\lib to
> apache-tomee-plus-1.0.0\lib folder (it was written as suggestion in JIRA).
> Then, I select Web->Dynamic Web Project, I set "Dynamic web module_version"=
> 3 and leave it to “Default Configuration for TomEE plus” on Eclipse. I
> successfully built the project but when I run it on the server I receive the
> following excpetion:
> 24 Απρ 2012 11:39:30 πμ org.apache.myfaces.webapp.AbstractFacesInitializer
> initFaces
> SEVERE: An error occured while initializing MyFaces: null
> java.lang.NullPointerException
> 	at
> org.apache.tomee.myfaces.TomEEAnnotationProvider.getAnnotatedClasses(TomEEAnnotationProvider.java:41)
> 	at
> org.apache.myfaces.config.annotation.AnnotationConfigurator.createFacesConfig(AnnotationConfigurator.java:90)
> 
> Do I have I do more settings and where? Shall I add JSF and JSTL libraries?
> Is the right way to test the REST examples in Eclipse as above?
> 
> Regards,
> kalgik
> 
> 
> --
> View this message in context: http://openejb.979440.n4.nabble.com/Problem-deploying-REST-Examples-on-Eclipse-tp4582815p4582815.html
> Sent from the OpenEJB User mailing list archive at Nabble.com.


Mime
View raw message