tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zeeman <hamz...@fastmail.us>
Subject Re: Tomee Maven plugin
Date Wed, 04 Jul 2012 19:55:23 GMT
There is some config issues either in plugin POM or my POM. I tried the same
setup on a different machine got the same thing. So please read this
carefully. I removed maven repo to start from scratch.

I use this repo https://repository.apache.org for plugins and dependencies 
in my POM.

I use this for plugin declaration:

<groupId>org.apache.openejb.maven</groupId>
<artifactId>tomee-maven-plugin</artifactId>
<version>1.0.0-SNAPSHOT</version> 

I package the war, I run mvn tomee:run I get the below:

[WARNING] The POM for
org.apache.openejb.maven:tomee-maven-plugin:jar:1.0.0-SNAPSHOT is missing,
no dependency information available
[WARNING] Failed to retrieve plugin descriptor for
org.apache.openejb.maven:tomee-maven-plugin:1.0.0-SNAPSHOT: Plugin
org.apache.openej
b.maven:tomee-maven-plugin:1.0.0-SNAPSHOT or one of its dependencies could
not be resolved: Failed to read artifact descriptor for org.
apache.openejb.maven:tomee-maven-plugin:jar:1.0.0-SNAPSHOT

[ERROR] No plugin found for prefix 'tomee' in the current project and in the
plugin groups [org.apache.maven.plugins, org.codehaus.mojo
] available from the repositories [local (C:\Users\zeeman\.m2\repository),
apache-maven-snapshots (https://repository.apache.org), c
entral (http://repo.maven.apache.org/maven2)] -> [Help 1]

Things would work on your machine because you have the plugin installed
locally. If you remove your maven repo, I bet you'll get the above error.
Any ideas?

--
View this message in context: http://openejb.979440.n4.nabble.com/Tomee-Maven-plugin-tp4655953p4656027.html
Sent from the OpenEJB User mailing list archive at Nabble.com.

Mime
View raw message