tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: javax.el.PropertyNotFoundException in JSF
Date Wed, 11 Jul 2012 06:59:59 GMT
How do you use javaee endorsed api?
Le 11 juil. 2012 08:12, "cri_sys" <serjec@gmail.com> a écrit :

> Thanks i have seen your POM.XML and validate the your dependicies, but
> still
> not working... here my dependencies, maybe is more clear:
>
>
>         <dependencies>
>                 <dependency>
>                         <groupId>org.apache.openejb</groupId>
>                         <artifactId>javaee-api</artifactId>
>                         <version>6.0-4</version>
>                         <scope>provided</scope>
>                 </dependency>
>                 <dependency>
>                         <groupId>org.primefaces</groupId>
>                         <artifactId>primefaces</artifactId>
>                         <version>3.2</version>
>                 </dependency>
>                 <dependency>
>                         <groupId>org.slf4j</groupId>
>                         <artifactId>slf4j-api</artifactId>
>                         <version>1.6.4</version>
>                         <scope>provided</scope>
>                 </dependency>
>
>                 <dependency>
>                         <groupId>org.apache.myfaces.core</groupId>
>                         <artifactId>myfaces-api</artifactId>
>                         <version>2.1.8</version>
>                         <scope>provided</scope>
>                 </dependency>
>                 <dependency>
>                         <groupId>org.apache.myfaces.core</groupId>
>                         <artifactId>myfaces-impl</artifactId>
>                         <version>2.1.8</version>
>                         <scope>provided</scope>
>                         <exclusions>
>                                 <exclusion>
>
> <artifactId>commons-collections</artifactId>
>
> <groupId>commons-collections</groupId>
>                                 </exclusion>
>                         </exclusions>
>                 </dependency>
>
>                 <dependency>
>                         <groupId>javax.servlet</groupId>
>                         <artifactId>jstl</artifactId>
>                         <version>1.2</version>
>                         <scope>provided</scope>
>                 </dependency>
>                 <dependency>
>                         <groupId>javax.servlet</groupId>
>                         <artifactId>servlet-api</artifactId>
>                         <version>2.5</version>
>                         <scope>provided</scope>
>                 </dependency>
>                 <dependency>
>                         <groupId>com.google.inject</groupId>
>                         <artifactId>guice</artifactId>
>                         <version>3.0</version>
>                         <scope>compile</scope>
>                 </dependency>
>                 <dependency>
>                         <groupId>com.google.inject.extensions</groupId>
>                         <artifactId>guice-servlet</artifactId>
>                         <version>3.0</version>
>                         <scope>compile</scope>
>                 </dependency>
>                 <dependency>
>                         <groupId>com.google.inject.extensions</groupId>
>                         <artifactId>guice-multibindings</artifactId>
>                         <version>3.0</version>
>                 </dependency>
>                 <dependency>
>                         <groupId>com.google.inject.extensions</groupId>
>                         <artifactId>guice-jndi</artifactId>
>                         <version>3.0</version>
>                 </dependency>
>                 <dependency>
>                         <groupId>com.ocpsoft</groupId>
>                         <artifactId>prettyfaces-jsf2</artifactId>
>                         <version>3.3.3</version>
>                 </dependency>
>
>                 <dependency>
>                         <groupId>junit</groupId>
>                         <artifactId>junit</artifactId>
>                         <version>4.8.2</version>
>                         <scope>test</scope>
>                 </dependency>
>
>                 <dependency>
>                         <groupId>org.primefaces.themes</groupId>
>                         <artifactId>smoothness</artifactId>
>                         <version>1.0.6</version>
>                 </dependency>
>         </dependencies>
>
>         <build>
>                 <plugins>
>                         <plugin>
>                                 <groupId>org.apache.maven.plugins</groupId>
>
> <artifactId>maven-compiler-plugin</artifactId>
>                                 <version>2.3.2</version>
>                                 <configuration>
>                                         <source>1.6</source>
>                                         <target>1.6</target>
>                                         <compilerArguments>
>
> <endorseddirs>${endorsed.dir}</endorseddirs>
>                                         </compilerArguments>
>                                 </configuration>
>                         </plugin>
>                         <plugin>
>                                 <groupId>org.apache.maven.plugins</groupId>
>                                 <artifactId>maven-war-plugin</artifactId>
>                                 <version>2.1.1</version>
>                                 <configuration>
>
> <failOnMissingWebXml>false</failOnMissingWebXml>
>                                 </configuration>
>                         </plugin>
>                         <plugin>
>                                 <groupId>org.apache.maven.plugins</groupId>
>
> <artifactId>maven-dependency-plugin</artifactId>
>                                 <version>2.1</version>
>                                 <executions>
>                                         <execution>
>                                                 <phase>validate</phase>
>                                                 <goals>
>                                                         <goal>copy</goal>
>                                                 </goals>
>                                                 <configuration>
>
> <outputDirectory>${endorsed.dir}</outputDirectory>
>
> <silent>true</silent>
>                                                         <artifactItems>
>
> <artifactItem>
>
> <groupId>javax</groupId>
>
> <artifactId>javaee-endorsed-api</artifactId>
>
> <version>6.0</version>
>
> <type>jar</type>
>
> </artifactItem>
>                                                         </artifactItems>
>                                                 </configuration>
>                                         </execution>
>                                 </executions>
>                         </plugin>
>                 </plugins>
>         </build>
> zeeman wrote
> >
> > Most likely you have a dependency problem. I have a project here
> > https://github.com/z00/test
> > check it out. You want to check out transitive dependencies to see what
> > you're missing (in Eclipse POM editor or command line mvn
> > dependency:tree).
> >
>
>
> --
> View this message in context:
> http://openejb.979440.n4.nabble.com/javax-el-PropertyNotFoundException-in-JSF-tp4656218p4656221.html
> Sent from the OpenEJB User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message