tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: OpenEJB Embedded - new://SecurityService?provider=...
Date Mon, 02 Jul 2012 18:56:39 GMT
Np, i did the same error when i started to use OpenEJB ;)

- Romain


2012/7/2 Elton Kuzniewski <elton.kuzniewski@softplan.com.br>

> Your hint was great! :D
>
> I just set "type" parameter and it works!
>
> properties.put("SPWContainerSecurityService",
>
> "new://SecurityService?type=SecurityService&provider=my.package.security#Som
> eSecurityService");
>
> Thanks Romain, I owe you a beer!
>
> Att,
>
> Elton Kuzniewski
> Analista de Sistemas
> SCJA, SCJP 5, SCWCD 5, SCBCD 5
> Pesquisa & Desenvolvimento | Softplan/Poligraph
> elton.kuzniewski@softplan.com.br
>
>
>
>
> -----Mensagem original-----
> De: Romain Manni-Bucau [mailto:rmannibucau@gmail.com]
> Enviada em: segunda-feira, 2 de julho de 2012 15:40
> Para: users@openejb.apache.org
> Assunto: Re: OpenEJB Embedded - new://SecurityService?provider=...
>
> hi,
>
> did you try providing type?
>
> - Romain
>
>
> 2012/7/2 Elton Kuzniewski <elton.kuzniewski@softplan.com.br>
>
> > Hi all,
> >
> > I'm trying to configure my own SecurityService by Properties using
> > new://SecurityService as below:
> >
> > properties.put("ContainerSecurityService", "new://SecurityService ");
> >
> > It works pretty well, but when I try  set my custom provider, configured
> at
> > service-jar.xml, it's not working as expected...
> >
> > My changes at SomeSecurityService (that extends SecurityServiceImpl from
> > openEJB) are not working as expected...
> >
> > properties.put("SPWContainerSecurityService",
> >
> "new://SecurityService?provider=my.package.security#SomeSecurityService");
> >
> > My Log:
> > INFO: Configuring Service(id=ContainerSecurityService,
> > type=SecurityService,
> > provider-id=SomeSecurityService)
> > INFO: Creating SecurityService(id=ContainerSecurityService)
> >
> > If I configure my custom provider at openejb.xml file, all features works
> > as
> > expected...
> >
> > I'm creating a Test API, that's because I'm not able to keep this
> > configuration into openejb.xml file.
> >
> > Anyone knows what's wrong? Why my custom provider is not working as
> > expected
> > when I declare it into Properties instead openejb.xml file?
> >
> > Thanks!
> >
> >
> > Att,
> >
> > Elton Kuzniewski
> > Analista de Sistemas
> > SCJA, SCJP 5, SCWCD 5, SCBCD 5
> > Pesquisa & Desenvolvimento | Softplan/Poligraph
> > elton.kuzniewski@softplan.com.br
> >
> >
> >
> >
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message