tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: CDI @Requires issue with Tomee
Date Sun, 08 Jul 2012 21:27:21 GMT
not sure (= didnt try) but maybe trying to play with alternative can do the
trick

the idea is to simply replace the class by another one.

Do you have idea of the classes needed?

if you only need some classes without their API maybe mocking them is the
easier (i'd personally try it)

- Romain


2012/7/8 zeeman <hamzah0@fastmail.us>

> jBoss Solder is what processes annotated @Required classes. You're right
> it's
> not from CDI. The class that does annotation processing from Solder is
> CoreExtension.
>
> I tried to veto the org.drools.KnowledgeBased package in @Required on Seam
> security RuleBasedPermissionResolver but I was not able to. Do you know if
> there is a way around this? I hate having to include jars for the sake of
> it.
>
> --
> View this message in context:
> http://openejb.979440.n4.nabble.com/CDI-Requires-issue-with-Tomee-tp4656112p4656153.html
> Sent from the OpenEJB User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message