tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Louis MONTEIRO <jeano...@gmail.com>
Subject Re: EJB 3.0 API
Date Fri, 19 Oct 2012 13:48:52 GMT
Hello,

4.x implements EJB 3.1
3.x implements EJB 3.0

But EJB 3.1 does not break compatibility AFAIR, then, you should be able to
use 4.x.

Could you share something (logs, etc)?

JLouis


2012/10/19 Miguel Figueiredo <ollliegator@gmail.com>

> Hello,
>
> I wan't to use OpenEJB in a JUnit environment in order to test EJBs with
> 3.0 API. Which OpenEJB version should I use for this purpose?
>
> For example I tried to use version 4.5.0 but I got the following error:
>
> FATAL - OpenEJB has encountered a fatal error and cannot be started: The
> Assembler encountered an unexpected error while attempting to build the
> container system.
> java.lang.NoSuchMethodError: javax.ejb.ApplicationException.inherited()Z
>     at
>
> org.apache.openejb.config.AnnotationDeployer$ProcessAnnotatedBeans.processApplicationExceptions(AnnotationDeployer.java:2665)
>
> Best regards,
> Miguel
>
> --
> Miguel Figueiredo
> Software Developer
> http://jaragua.dyndns.org
>
> "I'm a pretty lazy person and am prepared to work quite hard in order to
> avoid work."
> -- Martin Fowler
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message