tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Hodgins <michael_hodg...@hotmail.com>
Subject Maven Deploy, This principle is not authorized.
Date Mon, 07 Jan 2013 13:21:35 GMT
Hi

I've been playing around with the maven plugin for Tomee and I'm struggling
with the command 

mvn tomee:deploy

I've cloned the git repo Nicholas Frankel mentions in this post. 
http://blog.frankel.ch/pet-catalog-for-javaee-6-reengineered
<http://blog.frankel.ch/pet-catalog-for-javaee-6-reengineered>  . I've then
added this to the pom file:

<plugin>
     <groupId>org.apache.openejb.maven</groupId>
     <artifactId>tomee-maven-plugin</artifactId>
     <version>1.0.0</version>
     <configuration>
             <tomeeVersion>${tomee.version}</tomeeVersion>
             <tomeeClassifier>${tomee.classifier}</tomeeClassifier>
             <finalName>${project.build.finalName}</finalName>
             <user>tomee</user>
             <password>tomee</password>
             <path>pet</path>
             <config>${project.basedir}/src/main/tomee/conf</config>
     </configuration>
</plugin>

and I've copied a tomcat-users.xml into src/main/tomee/conf which has the
following:

<?xml version='1.0' encoding='utf-8'?>
<tomcat-users>
  <role rolename="tomcat"/>
  <role rolename="role1"/>
  <user username="tomcat" password="tomcat" roles="tomcat"/>
  <user username="both" password="tomcat" roles="tomcat,role1"/>
  <user username="role1" password="tomcat" roles="role1"/>
  <role rolename="tomee-admin" />
  <role rolename="manager-gui" />
  <user username="tomee" password="tomee" roles="tomee-admin,manager-gui" />
</tomcat-users>

When I run mvn tomee:start I see a message that my tomcat-users.xml file is
overriding the default one but when I run mvn tomee:deploy I get the
following message:

Failed to execute goal
org.apache.openejb.maven:tomee-maven-plugin:1.0.0:deploy (default-cli) on
project petcatalog: Execution default-cli of goal
org.apache.openejb.maven:tomee-maven-plugin:1.0.0:deploy failed: This
principle is not authorized. If I browse to http://localhost:8080/tomee I
can login with tomee:tomee.

What am I doing wrong?


Michael



--
View this message in context: http://openejb.979440.n4.nabble.com/Maven-Deploy-This-principle-is-not-authorized-tp4660120.html
Sent from the OpenEJB User mailing list archive at Nabble.com.

Mime
View raw message