tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From AlanHeath <alan.he...@edgeipk.com>
Subject clean install of openejb 4.5.1 is not working
Date Tue, 08 Jan 2013 16:26:12 GMT
I did the following
1. download 4.5.1 version of openejb
2. Installed it onto a windows 7 C:\programs
3. In a command window cd C:\programs\apache-openejb-4.5.1\bin
4. openejb start
    Everything seems ok The logfile looks ok ejbd 
    Jan 08, 2013 4:09:06 PM org.apache.openejb.server.SimpleServiceManager
printRow
    INFO:   ejbd                 127.0.0.1       4201
5. Open another command window, cd C:\programs\apache-openejb-4.5.1\bin
6. In the second command window openejb properties
   Jan 08, 2013 4:09:42 PM org.apache.openejb.client.EventLogger log
   INFO: RemoteInitialContextCreated{providerUri=ejbd://localhost:4201}
   Jan 08, 2013 4:09:42 PM org.apache.openejb.client.EventLogger log
   INFO: ConnectionOpened{uri=ejbd://localhost:4201}
   Jan 08, 2013 4:09:42 PM org.apache.openejb.client.EventLogger log
   INFO: ServerAdded{server=ejbds://127.0.0.1:4203}
ClusterMetaDataUpdated{provider
   =ejbd://localhost:4201, version=1357661341934, uris=2}
   Jan 08, 2013 4:09:42 PM org.apache.openejb.client.EventLogger log
   INFO: ServerAdded{server=ejbd://127.0.0.1:4201}
ClusterMetaDataUpdated{provider=
   ejbd://localhost:4201, version=1357661341934, uris=2}
   Jan 08, 2013 4:09:42 PM org.apache.openejb.client.EventLogger log
   INFO: ServerRemoved{server=ejbd://localhost:4201}  
   ClusterMetaDataUpdated{provider=ejbd://localhost:4201,
version=1357661341934, uris=2}
   ConfigurationInfo does not exist in server 'ejbd://localhost:4201', check
the server logs to ensure it 
   exists and has not been removed.


Now looking in the log file I get the following
  Jan 08, 2013 4:09:06 PM org.apache.openejb.server.SimpleServiceManager
start
  INFO: Ready!
  Jan 08, 2013 4:09:42 PM org.apache.openejb.client.EventLogger log
  INFO: RemoteInitialContextCreated{providerUri=ejbd://localhost:4201}
  Jan 08, 2013 4:09:42 PM org.apache.openejb.client.EventLogger log
  INFO: ConnectionOpened{uri=ejbd://localhost:4201}
  Jan 08, 2013 4:09:42 PM org.apache.openejb.client.EventLogger log
  INFO: ServerAdded{server=ejbds://127.0.0.1:4203}   
  ClusterMetaDataUpdated{provider=ejbd://localhost:4201,
version=1357661341934, uris=2}
  Jan 08, 2013 4:09:42 PM org.apache.openejb.client.EventLogger log
  INFO: ServerAdded{server=ejbd://127.0.0.1:4201}   
  ClusterMetaDataUpdated{provider=ejbd://localhost:4201,
version=1357661341934, uris=2}
  Jan 08, 2013 4:09:42 PM org.apache.openejb.client.EventLogger log
  INFO: ServerRemoved{server=ejbd://localhost:4201}     
  ClusterMetaDataUpdated{provider=ejbd://localhost:4201,
version=1357661341934, uris=2}

Looks like the server ejbd shut down for some reason.

I used netstat -a to check non of the ports are being used

Does anyone know why this is happening?
By the way my knowledge of EJB's is limited but I have not got to the step
of deploying an EJB yet.



--
View this message in context: http://openejb.979440.n4.nabble.com/clean-install-of-openejb-4-5-1-is-not-working-tp4660165.html
Sent from the OpenEJB User mailing list archive at Nabble.com.

Mime
View raw message