tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: Latest-version TomEE 1.5.2-SNAPSHOT (Tomcat 7.0.34?) just died on me, nothing in server logs
Date Thu, 31 Jan 2013 06:12:09 GMT
Do you know if atmo works with last tomcat?
Le 31 janv. 2013 06:36, "Howard W. Smith, Jr." <smithh032772@gmail.com> a
écrit :

> Atmosphere issue 875 added[1]
>
> [1] https://github.com/Atmosphere/atmosphere/issues/875
>
>
> On Wed, Jan 30, 2013 at 10:43 PM, Howard W. Smith, Jr. <
> smithh032772@gmail.com> wrote:
>
> > On Wed, Jan 30, 2013 at 10:34 PM, David Blevins <david.blevins@gmail.com
> >wrote:
> >
> >> On Jan 30, 2013, at 7:00 PM, "Howard W. Smith, Jr." <
> >> smithh032772@gmail.com> wrote:
> >>
> >> > Again/FYI, earlier this afternoon (around 12pm EST or EDT), I reverted
> >> to
> >> > TomEE 1.5.2-SNAPSHOT (2013-01-14, which is using tomcat7.0.34) and
> >> > Atmosphere 1.0.6, I don't see an issue. Atmosphere 1.0.8 was working
> >> well
> >> > with TomEE 1.5.2-SNAPSHOT (2013-01-14), too.
> >>
> >> Just to make sure it wasn't lost in the cracks, we did identify an issue
> >> with Atomosphere/TomEE.  In this file in the Atomosphere:
> >>
> >>
> >>
> https://github.com/Atmosphere/atmosphere/blob/master/modules/cpr/src/main/java/org/atmosphere/container/Tomcat7CometSupport.java#L129
> >>
> >> It has the following code:
> >>
> >>     String[] tomcatVersion =
> >>  config.getServletContext().getServerInfo().substring(14).split("\\.");
> >>
> >> This won't work because of recent updates in TomEE 1.5.2-SNAPSHOT which
> >> append "(TomEE)" onto the ServerInfo string -- only skipping 14
> characters
> >> is not enough.  Romain gave the workaround of reverting to the old,
> >> unmodified, ServerInfo string via the System property
> >> "tomee.keep-server-info=true"
> >>
> >> Note that if the "tomee.keep-server-info" was successfully set to true,
> >> it will be logged on INFO level.  If the default of false is used, the
> >> checking of the 'tomee.keep-server-info' is still logged, but on DEBUG
> >> level.
> >>
> >> Is it possible you can confirm that you have tried the system property,
> >> see the expected log output, and the issue still exists?
> >>
> >>
> >> -David
> >>
> >>
> > sometime earlier, i added the system property to tomcat7w.exe java
> > options, and it is currently running against earlier version of TomEE
> > 1.5.2-SNAPSHOT (that has tomcat 7.0.34 dependency).
> >
> > Next/now, I will download latest version of TomEE 1.5.2-SNAPSHOT, and
> > install to production server, and leave it running, and see what happens.
> > honestly, I don't think the 'atmosphere issue' is causing the
> tomee/tomcat7
> > service to 'stop' running. that is possibly caused by another/separate
> > issue (either atmosphere or tomcat7.0.35 issue); that's my opinion.
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message