tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: Latest-version TomEE 1.5.2-SNAPSHOT (Tomcat 7.0.34?) just died on me, nothing in server logs
Date Thu, 31 Jan 2013 19:14:04 GMT
Bench you'll see ;)

For me nio connector is often enough
Le 31 janv. 2013 19:46, "Howard W. Smith, Jr." <smithh032772@gmail.com> a
écrit :

> Never mind...
>
> I found the following,
>
>
> http://stackoverflow.com/questions/8716259/what-does-the-apr-based-apache-tomcat-native-library-was-not-found-mean
>
> and that hinted that I needed to copy 'tcnative-1.dll' from tomcat7/bin to
> tomee/bin, and now APR is loaded. Do you think it is better for me to
> configure/use NIO connector instead?
>
>
>
> On Thu, Jan 31, 2013 at 1:34 PM, Howard W. Smith, Jr. <
> smithh032772@gmail.com> wrote:
>
> > Hmm, is the tomcat APR included in tomee/bin? I appended tomee/bin to
> > windows system %PATH%, and I still get the following error after starting
> > tomee.
> >
> >
> > 2013-01-31 13:28:17 Commons Daemon procrun stderr initialized
> > Jan 31, 2013 1:28:18 PM org.apache.catalina.core.AprLifecycleListener
> init
> > INFO: The APR based Apache Tomcat Native library which allows optimal
> > performance in production environments was not found on the
> > java.library.path:
> >
> D:\apache-tomee-plus-1.5.2-SNAPSHOT\bin;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;D:\apache-tomee-plus-1.5.2-SNAPSHOT\bin;.
> >
> >
> > On Thu, Jan 31, 2013 at 9:59 AM, Romain Manni-Bucau <
> rmannibucau@gmail.com
> > > wrote:
> >
> >> %PATH% -> apr
> >>
> >> then regarding perf it is not tomee related but tomcat
> >>
> >> it enhances perf in some cases and degrades them in some
> others...depends
> >> the app
> >>
> >> *Romain Manni-Bucau*
> >> *Twitter: @rmannibucau <https://twitter.com/rmannibucau>*
> >> *Blog: **http://rmannibucau.wordpress.com/*<
> >> http://rmannibucau.wordpress.com/>
> >> *LinkedIn: **http://fr.linkedin.com/in/rmannibucau*
> >> *Github: https://github.com/rmannibucau*
> >>
> >>
> >>
> >> 2013/1/31 Howard W. Smith, Jr. <smithh032772@gmail.com>
> >>
> >> > add it to your win %PATH% ?  'it' = ? it = tomee/bin folder to %PATH%
> ?
> >> >
> >> > will not make app faster in all cases? so, tomee (committers) does not
> >> > recommend use of APR for faster performance? please let me know,
> >> because if
> >> > I remove APR, then I'm assuming APR = tomcat native, and that already
> >> > (along with other changes made today or this morning) resolves the
> issue
> >> > where tomee (or tomcat7 service) does not 'stop' unexpectedly because
> of
> >> > some conflict between atmosphere and tcnative.
> >> >
> >> >
> >> >
> >> > On Thu, Jan 31, 2013 at 9:49 AM, Romain Manni-Bucau
> >> > <rmannibucau@gmail.com>wrote:
> >> >
> >> > > add it to your win %PATH%
> >> > >
> >> > > but you know it will not make your app faster in all cases?
> >> > >
> >> > > the message is a bit wrong on that point
> >> > >
> >> > > *Romain Manni-Bucau*
> >> > > *Twitter: @rmannibucau <https://twitter.com/rmannibucau>*
> >> > > *Blog: **http://rmannibucau.wordpress.com/*<
> >> > > http://rmannibucau.wordpress.com/>
> >> > > *LinkedIn: **http://fr.linkedin.com/in/rmannibucau*
> >> > > *Github: https://github.com/rmannibucau*
> >> > >
> >> > >
> >> > >
> >> > > 2013/1/31 Howard W. Smith, Jr. <smithh032772@gmail.com>
> >> > >
> >> > > > Okay, this has always concerned me, even when I see this in the
> log
> >> on
> >> > my
> >> > > > development machine, which uses tomee startup scripts, when I
> start
> >> > tomee
> >> > > > via Netbeans - Servers - right-click TomEE, and select Start
or
> >> Stop.
> >> > > >
> >> > > >
> >> > > > When I use tomcat7/bin service.bat to install 'tomcat7' default
> >> windows
> >> > > > service, I see the following in the log (APR is loaded
> successfully,
> >> > > > always)
> >> > > >
> >> > > > 2013-01-31 01:57:12 Commons Daemon procrun stderr initialized
> >> > > > Jan 31, 2013 1:57:17 AM
> >> org.apache.catalina.core.AprLifecycleListener
> >> > > init
> >> > > > INFO: Loaded APR based Apache Tomcat Native library 1.1.24 using
> APR
> >> > > > version 1.4.6.
> >> > > > Jan 31, 2013 1:57:17 AM
> >> org.apache.catalina.core.AprLifecycleListener
> >> > > init
> >> > > > INFO: APR capabilities: IPv6 [true], sendfile [true], accept
> filters
> >> > > > [false], random [true].
> >> > > > Jan 31, 2013 1:57:19 AM
> >> org.apache.catalina.core.AprLifecycleListener
> >> > > > initializeSSL
> >> > > > INFO: OpenSSL successfully initialized (OpenSSL 1.0.1c 10 May
> 2012)
> >> > > >
> >> > > >
> >> > > > But when I use tomee/bin service.bat to install tomee windows
> >> service
> >> > > (and
> >> > > > when I start tomee server via Netbeans/tomee mgr scripts), I
see
> the
> >> > > > following on development server (and now on production server)
> >> > > >
> >> > > > 2013-01-31 09:01:41 Commons Daemon procrun stderr initialized
> >> > > > Jan 31, 2013 9:01:43 AM
> >> org.apache.catalina.core.AprLifecycleListener
> >> > > init
> >> > > > INFO: The APR based Apache Tomcat Native library which allows
> >> optimal
> >> > > > performance in production environments was not found on the
> >> > > > java.library.path:
> >> > > >
> >> > > >
> >> > >
> >> >
> >>
> D:\apache-tomee-plus-1.5.2-SNAPSHOT\bin;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;;.
> >> > > >
> >> > > > Please advise how i can get APR loaded successfully using tomee
> >> > > > scripts/service/etc...
> >> > > >
> >> > > >
> >> > > > On Thu, Jan 31, 2013 at 9:24 AM, Howard W. Smith, Jr. <
> >> > > > smithh032772@gmail.com> wrote:
> >> > > >
> >> > > > > Okay, now that I'm using tomee service exe, as per Romain's
> >> > suggestion,
> >> > > > > and already updated max perm size as per Mark's suggestion
and
> >> > > restarted
> >> > > > > server on production server... a quick update:
> >> > > > >
> >> > > > > 1. Downloaded, installed, and
> >> > > > > running apache-tomee-1.5.2-20130130.041108-54-plus.zip on
> >> production
> >> > > > server
> >> > > > > (Windows Server 2008 64bit 32GB RAM)
> >> > > > >
> >> > > > > 2. Also added -Dtomee.keep-server-info=true, as Romain suggested
> >> > > earlier
> >> > > > >
> >> > > > > 3. Reverted to and running Atmosphere 1.0.6; why? because
from
> >> what I
> >> > > > > remember/witnessed, tomee/tomcat7 service stopped unexpectedly
> >> with
> >> > > > > Atmosphere 1.0.8, 1.0.9, and 1.0.6 (in that order) without
the
> >> > > > > -Dtomee.keep-server-info=true, when running with tomee
> >> 1.5.2-SNAPSHOT
> >> > > > build
> >> > > > > 2013-01-28 between the dates of 2013-01-28 and 2013-01-30
> >> > > > >
> >> > > > > 4. Even though the web app (and tomee) has not been under
load
> >> (yet,
> >> > > > > today) like it was yesterday morning and afternoon, I have
not
> >> seen
> >> > > > issue #
> >> > > > > 1 (tomee stopping, unexpectedly, with core dump) or # 2
> >> (atmosphere
> >> > > > "(TomEE)/7"
> >> > > > > numberFormatException), as mentioned/discussed in OP and
> >> throughout
> >> > > this
> >> > > > > thread, ever since I added -Dtomee.keep-server-info=true
> >> > > > >
> >> > > > > 5. Actually, I am considering re-adding Atmosphere 1.0.8
or
> 1.0.9
> >> to
> >> > > the
> >> > > > > mix, just to see/confirm if tomee will stop, unexpectedly,
with
> a
> >> > > > > resulting-core-dump in tomee/bin like it did (at least)
3 times
> in
> >> > > > > tomcat7/bin, when this issue occurred in the last 3 days.
> >> > > > >
> >> > > > > 6. still waiting patiently for Atmosphere 1.0.10 to be released,
> >> > which
> >> > > > > includes fix for atmosphere "(TomEE)/7" numberFormatException,
> >> along
> >> > > with
> >> > > > > other fixes that was targeting PrimeFaces Push (PrimeFaces
> >> > > 3.5-SNAPSHOT)
> >> > > > > and non-PrimeFaces-Push users (I assume).
> >> > > > >
> >> > > > >
> >> > > > >
> >> > > > > On Thu, Jan 31, 2013 at 6:20 AM, Romain Manni-Bucau <
> >> > > > rmannibucau@gmail.com
> >> > > > > > wrote:
> >> > > > >
> >> > > > >> tomcat supports websockets but no link with atmosphere
(maybe
> >> > > > classloader
> >> > > > >> issue in your app, check deps)
> >> > > > >>
> >> > > > >> maybe try using tomee service exe instead of tomcat
ones too
> >> > > > >>
> >> > > > >> *Romain Manni-Bucau*
> >> > > > >> *Twitter: @rmannibucau <https://twitter.com/rmannibucau>*
> >> > > > >> *Blog: **http://rmannibucau.wordpress.com/*<
> >> > > > >> http://rmannibucau.wordpress.com/>
> >> > > > >> *LinkedIn: **http://fr.linkedin.com/in/rmannibucau*
> >> > > > >> *Github: https://github.com/rmannibucau*
> >> > > > >>
> >> > > > >>
> >> > > >
> >> > >
> >> >
> >>
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message