tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Schlichtherle <christian-b...@schlichtherle.de>
Subject Re: Subscription to Topic is not receiving messages
Date Thu, 22 Aug 2013 15:54:56 GMT
Hi,

I am still desperately in need for a solution. Apparently the second subscriber to a topic
never receives a message. Actually, this is a showstopper, but unfortunately my customer depends
on Tomcat, so I need to find a solution. Any hints are greatly appreciated.

Update: I am now using durable subscriptions for both the agents and managers. Not sure if
that makes a difference.

Regards,
Christian Schlichtherle

Am 21.08.2013 um 18:15 schrieb Christian Schlichtherle <christian@schlichtherle.de>:

> Hi,
> 
> I have two components which represent different roles in an asynchronous conversation,
named agent and manager. There can be many agents, but there should be only one manager.
> 
> For the exchange of messages each instance subscribes to the same Topic. Only the manager
uses a durable subscription, agents don't care for messages received while they are offline.
The components filter messages which are not attributed to them.
> 
> This all works well when running the apps on Glassfish. On TomEE+ however, the agents
send messages and the manager receives them and responds to them, however, the agents never
receive a response. It also appears that the manager doesn't see the messages it sent although
the "noLocal" property has not been set.
> 
> What am I doing wrong? Do I need to configure my stock TomEE+ 1.5.2 to make this scenario
work?
> 
> Regards,
> Christian
> 
> 
> 


Mime
View raw message