tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Charles Moulliard <ch0...@gmail.com>
Subject Re: MANIFEST generated commons-lang import
Date Mon, 03 Feb 2014 08:12:56 GMT
Hi Ronny,

Which version of open-ejb would you like to deploy ? You can tranform a non
OSGI jar file into a OSGI Bundle using the wrap instruction

install -s wrap:org.apache.commons/commons-lang3/3.1

Regards,



On Fri, Jan 31, 2014 at 8:58 PM, Ronny Bräunlich <r.braeunlich@gmail.com>wrote:

> Hello everyone,
>
> I wanted to drop the openejb-core module into Karaf 3.
> When trying to start the bundle OSGi couldn't resolve the import
> org.apache.commons.lang;version="[3.1,4.0)".
> As far as I know there is no version >3 of that package because the name
> changed to org.apache.commons.lang3.
> Am I wrong or should someone correct the "openejb.osgi.import.pkg"
> property in the POM?
>
> Cheers,
> Ronny




-- 
Charles Moulliard
Apache Committer / Architect @RedHat
Twitter : @cmoulliard | Blog :  http://cmoulliard.github.io

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message