tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Muhammed Olgun <mh.ol...@gmail.com>
Subject Re: TomEE Arquillian Duplicate DeploymentID
Date Tue, 18 Mar 2014 08:39:41 GMT
I've created the issue https://issues.apache.org/jira/browse/TOMEE-1143


2014-03-18 10:28 GMT+02:00 Romain Manni-Bucau <rmannibucau@gmail.com>:

> PS: a patch fixing it for this case if you set solar as testable =
> false in your test (in @Deployment):
> https://gist.github.com/rmannibucau/c5d27b2cef546186f358
> Romain Manni-Bucau
> Twitter: @rmannibucau
> Blog: http://rmannibucau.wordpress.com/
> LinkedIn: http://fr.linkedin.com/in/rmannibucau
> Github: https://github.com/rmannibucau
>
>
>
> 2014-03-18 9:25 GMT+01:00 Romain Manni-Bucau <rmannibucau@gmail.com>:
> > Hi
> >
> > that's a bug you can open an issue
> > Romain Manni-Bucau
> > Twitter: @rmannibucau
> > Blog: http://rmannibucau.wordpress.com/
> > LinkedIn: http://fr.linkedin.com/in/rmannibucau
> > Github: https://github.com/rmannibucau
> >
> >
> >
> > 2014-03-18 8:39 GMT+01:00 Muhammed Olgun <mh.olgun@gmail.com>:
> >> Hi Romain,
> >>
> >> I got a unexpected work yesterday. I've just created a github project
> >> because of that.
> >>
> >> https://github.com/molgun/tomee-arquillian-embedded-solr-deployment
> >>
> >> When I run mvn clean install, I'm still getting same error. Also I
> removed
> >> -D tag.
> >>
> >>
> >>
> >> 2014-03-18 0:26 GMT+02:00 Romain Manni-Bucau <rmannibucau@gmail.com>:
> >>
> >>> Ps: for solar syst prop remove -D to let it be taken as expected ;)
> >>> Le 17 mars 2014 14:56, "Muhammed Olgun" <mh.olgun@gmail.com> a écrit
:
> >>>
> >>> > Ok, I'm on it and I will let you know when I create a github project.
> >>> >
> >>> >
> >>> > 2014-03-17 15:49 GMT+02:00 Romain Manni-Bucau <rmannibucau@gmail.com
> >:
> >>> >
> >>> > > well i expected something ready to run to be honest, a github
> project
> >>> > > or something like that
> >>> > > Romain Manni-Bucau
> >>> > > Twitter: @rmannibucau
> >>> > > Blog: http://rmannibucau.wordpress.com/
> >>> > > LinkedIn: http://fr.linkedin.com/in/rmannibucau
> >>> > > Github: https://github.com/rmannibucau
> >>> > >
> >>> > >
> >>> > >
> >>> > > 2014-03-17 14:45 GMT+01:00 Muhammed Olgun <mh.olgun@gmail.com>:
> >>> > > > Of course, these are my test classes,
> >>> > > >
> >>> > > > public abstract class AbstractServiceIT {
> >>> > > >
> >>> > > >     @Deployment(name="main",order=1)
> >>> > > >     public static JavaArchive createDeployment() {
> >>> > > >         JavaArchive archive =
> ShrinkWrap.create(JavaArchive.class)
> >>> > > >                 .addPackages(true, "com.example.ejbs")
> >>> > > >                 .addAsManifestResource(EmptyAsset.INSTANCE,
> >>> > "beans.xml");
> >>> > > >         System.out.println(archive.toString(true));
> >>> > > >         return archive;
> >>> > > >     }
> >>> > > > }
> >>> > > >
> >>> > > > @RunWith(Arquillian.class)
> >>> > > > public class SearchServiceSolrImplIT extends AbstractServiceIT
{
> >>> > > >
> >>> > > >     @Deployment(name="solr",order=2)
> >>> > > >     public static WebArchive solrDeploy() {
> >>> > > >         WebArchive archive = ShrinkWrap.create(ZipImporter.class,
> >>> > > > "solr.war")
> >>> > > >                 .importFrom(new
> >>> > > File("src/test/resources/solr-4.3.0.war"))
> >>> > > >                 .as(WebArchive.class);
> >>> > > >         return archive;
> >>> > > >     }
> >>> > > >
> >>> > > > }
> >>> > > >
> >>> > > > My pom.xml
> >>> > > >
> >>> > > > <profile>
> >>> > > >             <id>tomee-embedded</id>
> >>> > > >             <activation>
> >>> > > >                 <activeByDefault>false</activeByDefault>
> >>> > > >             </activation>
> >>> > > >             <dependencies>
> >>> > > >                 <dependency>
> >>> > > >                     <groupId>org.apache.openejb</groupId>
> >>> > > >                     <artifactId>javaee-api</artifactId>
> >>> > > >                     <version>6.0-6-SNAPSHOT</version>
> >>> > > >                     <scope>provided</scope>
> >>> > > >                 </dependency>
> >>> > > >                 <dependency>
> >>> > > >                     <groupId>org.apache.openejb</groupId>
> >>> > > >
> >>> <artifactId>arquillian-tomee-embedded</artifactId>
> >>> > > >                     <version>1.6.1-SNAPSHOT</version>
> >>> > > >                     <scope>test</scope>
> >>> > > >                 </dependency>
> >>> > > >                 <!-- SLF4J -->
> >>> > > >                 <dependency>
> >>> > > >                     <groupId>org.slf4j</groupId>
> >>> > > >                     <artifactId>slf4j-api</artifactId>
> >>> > > >                     <version>1.7.5</version>
> >>> > > >                 </dependency>
> >>> > > >                 <dependency>
> >>> > > >                     <groupId>org.slf4j</groupId>
> >>> > > >                     <artifactId>jcl-over-slf4j</artifactId>
> >>> > > >                     <version>1.7.5</version>
> >>> > > >                 </dependency>
> >>> > > >                 <dependency>
> >>> > > >                     <groupId>org.slf4j</groupId>
> >>> > > >                     <artifactId>jul-to-slf4j</artifactId>
> >>> > > >                     <version>1.7.5</version>
> >>> > > >                 </dependency>
> >>> > > >                 <dependency>
> >>> > > >                     <groupId>org.slf4j</groupId>
> >>> > > >                     <artifactId>slf4j-log4j12</artifactId>
> >>> > > >                     <version>1.7.5</version>
> >>> > > >                 </dependency>
> >>> > > >                 <!-- Log4j -->
> >>> > > >                 <dependency>
> >>> > > >                     <groupId>log4j</groupId>
> >>> > > >                     <artifactId>log4j</artifactId>
> >>> > > >                     <version>1.2.17</version>
> >>> > > >                 </dependency>
> >>> > > >             </dependencies>
> >>> > > >         </profile>
> >>> > > >
> >>> > > > My arquillian.xml
> >>> > > >
> >>> > > > <arquillian xmlns="http://jboss.org/schema/arquillian"
> >>> > > >             xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance
> "
> >>> > > >             xsi:schemaLocation="
> >>> > > >         http://jboss.org/schema/arquillian
> >>> > > >         http://jboss.org/schema/arquillian/arquillian_1_0.xsd">
> >>> > > >     <container qualifier="tomee" default="true">
> >>> > > >         <configuration>
> >>> > > >             <property name="httpPort">-1</property>
> >>> > > >             <property name="stopPort">-1</property>
> >>> > > >             <property name="dir">target/tomee-embedded</property>
> >>> > > >             <property
> >>> > name="appWorkingDir">target/working-dir</property>
> >>> > > >             <property name="properties">
> >>> > > >                 openejb.deploymentId.format={moduleId}/{ejbName}
> >>> > > >
> >>> > > > -Dsolr.solr.home=/Users/molgun/Downloads/solr-4.6.1/example/solr
> >>> > > >             </property>
> >>> > > >         </configuration>
> >>> > > >     </container>
> >>> > > > </arquillian>
> >>> > > >
> >>> > > >
> >>> > > > 2014-03-17 15:37 GMT+02:00 Romain Manni-Bucau <
> rmannibucau@gmail.com
> >>> >:
> >>> > > >
> >>> > > >> Hi
> >>> > > >>
> >>> > > >> can you reproduce it and share the sample? I doubt it
is an
> aadatper
> >>> > > issue.
> >>> > > >> Romain Manni-Bucau
> >>> > > >> Twitter: @rmannibucau
> >>> > > >> Blog: http://rmannibucau.wordpress.com/
> >>> > > >> LinkedIn: http://fr.linkedin.com/in/rmannibucau
> >>> > > >> Github: https://github.com/rmannibucau
> >>> > > >>
> >>> > > >>
> >>> > > >>
> >>> > > >> 2014-03-17 14:22 GMT+01:00 Muhammed Olgun <mh.olgun@gmail.com>:
> >>> > > >> > I made two deployments with TomEE-Arquillian Embedded
but I
> got
> >>> > > >> >
> >>> > > >> > *org.apache.openejb.DuplicateDeploymentIdException:
> Application
> >>> > > cannot be
> >>> > > >> > deployed as it contains deployment-ids which are
in use*
> >>> > > >> >
> >>> > > >> > So, I edited my arquillian.xml like this;
> >>> > > >> >
> >>> > > >> > <arquillian xmlns="http://jboss.org/schema/arquillian"
> >>> > > >> >             xmlns:xsi="
> http://www.w3.org/2001/XMLSchema-instance"
> >>> > > >> >             xsi:schemaLocation="
> >>> > > >> >         http://jboss.org/schema/arquillian
> >>> > > >> >         http://jboss.org/schema/arquillian/arquillian_1_0.xsd
> ">
> >>> > > >> >     <container qualifier="tomee" default="true">
> >>> > > >> >         <configuration>
> >>> > > >> >             <property name="httpPort">-1</property>
> >>> > > >> >             <property name="stopPort">-1</property>
> >>> > > >> >             <property
> name="dir">target/tomee-embedded</property>
> >>> > > >> >             <property
> >>> > > name="appWorkingDir">target/working-dir</property>
> >>> > > >> >             <property name="properties">
> >>> > > >> >
> openejb.deploymentId.format={moduleId}/{ejbName}
> >>> > > >> >
> >>> > > >> >
> -Dsolr.solr.home=/Users/molgun/Downloads/solr-4.6.1/example/solr
> >>> > > >> >             </property>
> >>> > > >> >         </configuration>
> >>> > > >> >     </container>
> >>> > > >> > </arquillian>
> >>> > > >> >
> >>> > > >> > and I see from log console;
> >>> > > >> >
> >>> > > >> > Mar 17, 2014 3:21:17 PM org.apache.openejb.util.OptionsLog
> info
> >>> > > >> > INFO: Using 'openejb.deploymentId.format={moduleId}/{ejbName}'
> >>> > > >> >
> >>> > > >> > but I'm getting still same error. Should I create
a ticket or
> did
> >>> I
> >>> > > miss
> >>> > > >> > something?
> >>> > > >>
> >>> > >
> >>> >
> >>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message