tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: CDI not working inside EAR with Atmosphere (BeanManager)
Date Tue, 22 Apr 2014 23:17:02 GMT
surely linked to https://issues.apache.org/jira/browse/TOMEE-1183


Romain Manni-Bucau
Twitter: @rmannibucau
Blog: http://rmannibucau.wordpress.com/
LinkedIn: http://fr.linkedin.com/in/rmannibucau
Github: https://github.com/rmannibucau


2014-04-22 18:36 GMT+02:00 José Luis Cetina <maxtorzito@gmail.com>:
> My tomee runs already under C:\tomee, in the related topic, i uploaded a
> maven project that you can check it, this is a TomEE problem.
>
>
> 2014-04-22 11:28 GMT-05:00 Romain Manni-Bucau <rmannibucau@gmail.com>:
>
>> Well first check basic things like spaces etc, can be a hidden bug
>> until now. Basically try to deploy in c:\tomee. If the issue is still
>> here we'll try to have a deeper look. But we have a lot of win users
>> and a really blocking win issue would have popped earlier I guess.
>>
>>
>> Romain Manni-Bucau
>> Twitter: @rmannibucau
>> Blog: http://rmannibucau.wordpress.com/
>> LinkedIn: http://fr.linkedin.com/in/rmannibucau
>> Github: https://github.com/rmannibucau
>>
>>
>> 2014-04-22 18:25 GMT+02:00 José Luis Cetina <maxtorzito@gmail.com>:
>> > Hi, my problem was i mean IS with CODI using Windows.
>> >
>> > Here is the conversation:
>> >
>> http://openejb.979440.n4.nabble.com/No-bean-found-for-type-org-apache-myfaces-extensions-cdi-jsf-api-config-JsfModuleConfig-td4666654.html
>> >
>> > @Romain, maybe this is realted i hope you can have a windows pc for check
>> > it!!
>> >
>> >
>> >
>> > 2014-04-22 11:09 GMT-05:00 Howard W. Smith, Jr. <smithh032772@gmail.com
>> >:
>> >
>> >> Jose' can advise on this when he gets some time. Jose' is doing EARs +
>> CDI
>> >> + TomEE for some/many months now.
>> >>
>> >> Jose', please advise on this topic at your earliest convenience.
>> >>
>> >> I think Jose' had to use BeanManager and had to use the JNDI name
>> specified
>> >> in the tomee/catalina log when tomee starts. I could be wrong.
>> >>
>> >>
>> >>
>> >> On Tue, Apr 22, 2014 at 12:04 PM, Lars Knemeyer <
>> lars.knemeyer@gmail.com
>> >> >wrote:
>> >>
>> >> > Ok, the problem seems to be platform-related.
>> >> >
>> >> > I started the same TomEE 1.6.1 SNAPHOT on two Windows 7 systems and
>> one
>> >> > Windows Server 2008 R2 (all with the latest JDK 7_55) and it failed
in
>> >> all
>> >> > three cases (with the described error).
>> >> > Then I started the same TomEE server (I used the same prepared zip
in
>> all
>> >> > cases) on a (virtual) Ubuntu 13.10 machine with OpenJDK as well as
>> Oracle
>> >> > JDK and in both cases the sample worked without a problem (as you
>> >> described
>> >> > it).
>> >> >
>> >> > So it seems to be a Windows-specific problem (I first suspected it's
>> the
>> >> > Oracle JDK, but it works with that also on Ubuntu). I just don't know
>> >> what
>> >> > to do with this finding.
>> >> >
>> >> >
>> >> >
>> >> > --
>> >> > View this message in context:
>> >> >
>> >>
>> http://openejb.979440.n4.nabble.com/CDI-not-working-inside-EAR-with-Atmosphere-BeanManager-tp4668939p4668948.html
>> >> > Sent from the OpenEJB User mailing list archive at Nabble.com.
>> >> >
>> >>
>> >
>> >
>> >
>> > --
>> > -------------------------------------------------------------------
>> > *José Luis Cetina*
>> > -------------------------------------------------------------------
>>
>
>
>
> --
> -------------------------------------------------------------------
> *José Luis Cetina*
> -------------------------------------------------------------------

Mime
View raw message