tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Howard W. Smith, Jr." <smithh032...@gmail.com>
Subject Re: CDI not working inside EAR with Atmosphere (BeanManager)
Date Tue, 22 Apr 2014 16:09:57 GMT
Jose' can advise on this when he gets some time. Jose' is doing EARs + CDI
+ TomEE for some/many months now.

Jose', please advise on this topic at your earliest convenience.

I think Jose' had to use BeanManager and had to use the JNDI name specified
in the tomee/catalina log when tomee starts. I could be wrong.



On Tue, Apr 22, 2014 at 12:04 PM, Lars Knemeyer <lars.knemeyer@gmail.com>wrote:

> Ok, the problem seems to be platform-related.
>
> I started the same TomEE 1.6.1 SNAPHOT on two Windows 7 systems and one
> Windows Server 2008 R2 (all with the latest JDK 7_55) and it failed in all
> three cases (with the described error).
> Then I started the same TomEE server (I used the same prepared zip in all
> cases) on a (virtual) Ubuntu 13.10 machine with OpenJDK as well as Oracle
> JDK and in both cases the sample worked without a problem (as you described
> it).
>
> So it seems to be a Windows-specific problem (I first suspected it's the
> Oracle JDK, but it works with that also on Ubuntu). I just don't know what
> to do with this finding.
>
>
>
> --
> View this message in context:
> http://openejb.979440.n4.nabble.com/CDI-not-working-inside-EAR-with-Atmosphere-BeanManager-tp4668939p4668948.html
> Sent from the OpenEJB User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message