tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From david Cossé <co...@codelutin.com>
Subject Upgrade from 4.5.2 to 4.6.0.1 issue
Date Mon, 12 May 2014 11:59:00 GMT
After ugrading the openEJB version from 4.5.2 to 4.6.0.1, when using 
java -jar to launch my application it doesn't start and throw up this 
exception:

Erreur

Message:
     org.apache.openejb.OpenEjbContainer$NoModulesFoundException: No 
modules found to deploy.
1)Maybe descriptors are placed in incorrect location.
Descriptors could go under:
<base-dir>/META-INF or <base-dir>/WEB-INF
but not directly under <base-dir>
Check 'Application Discovery via the Classpath' docs page for more info
2)Maybe no modules are present in the classpath.
Is 'openejb.base' system property pointing to the intended location?
Level:
     SEVERE
Stack Trace:
No modules found to deploy. 1)Maybe descriptors are placed in incorrect 
location. Descriptors could go under:  /META-INF or /WEB-INF but not 
directly under   Check 'Application Discovery via the Classpath' docs 
page for more info 2)Maybe no modules are present in the classpath. Is 
'openejb.base' system property pointing to the intended location?
org.apache.openejb.util.Exceptions.newNoModulesFoundException(Exceptions.java:98)
org.apache.openejb.OpenEjbContainer$Provider.load(OpenEjbContainer.java:549)
org.apache.openejb.OpenEjbContainer$Provider.createEJBContainer(OpenEjbContainer.java:354)
javax.ejb.embeddable.EJBContainer.createEJBContainer(EJBContainer.java:56)
org.chorem.lima.service.LimaServiceFactory.initFactory(LimaServiceFactory.java:92)
     org.chorem.lima.LimaMain.launch(LimaMain.java:136)
     org.chorem.lima.LimaMain.main(LimaMain.java:88)

Thanks for your help.
David cossé


Mime
View raw message