tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: Upgrade from 4.5.2 to 4.6.0.1 issue
Date Tue, 13 May 2014 14:35:10 GMT
Hi

seems there isn't business jar in lima-swing.jar (not sure I built the
project as expected then). If so nothing if found to deploy. If you
want to force it ensure you have under META-INF an ejb-jar.xml or a
beans.xml for instance. Testing on trunk and seems  it deploys further
but fails cause business is missing.


Romain Manni-Bucau
Twitter: @rmannibucau
Blog: http://rmannibucau.wordpress.com/
LinkedIn: http://fr.linkedin.com/in/rmannibucau
Github: https://github.com/rmannibucau


2014-05-13 15:33 GMT+02:00 david Cossé <cosse@codelutin.com>:
> Yes it is.
> Lima is a stand alone application and use OpenEJb in an embedded mode.
> If you wish you can have a look to the lima project from our forge:
> http://www.chorem.org/projects/lima/repository/show/tags/lima-0.7.2
>
> On this release there was not the scan.xml file but I tried to add it and it
> did not get better.
>
>
> The error message says:
>
> org.apache.openejb.OpenEjbContainer$NoModulesFoundException: No modules
> found to deploy.
> 1)Maybe descriptors are placed in incorrect location.
> Descriptors could go under:
> <base-dir>/META-INF or <base-dir>/WEB-INF
> but not directly under <base-dir>
> Check 'Application Discovery via the Classpath' docs page for more info
> 2)Maybe no modules are present in the classpath.
>
> but i've got an ejb-jar.xml file under the buisiness witch is into the
> classpath.
> The file is used if when having openejb version 4.5.2
>
>
> thanks for your help
>
>
>
> Le 13/05/2014 10:16, Romain Manni-Bucau a écrit :
>
>> are you sure you don't have openejb-core scan.xml in your uber jar?
>>
>>
>> Romain Manni-Bucau
>> Twitter: @rmannibucau
>> Blog: http://rmannibucau.wordpress.com/
>> LinkedIn: http://fr.linkedin.com/in/rmannibucau
>> Github: https://github.com/rmannibucau
>>
>>
>> 2014-05-13 9:46 GMT+02:00 david Cossé <cosse@codelutin.com>:
>>>
>>> I did it but it doesn't solve the problem.
>>> Thanks
>>>
>>>
>>> Le 12/05/2014 17:16, Romain Manni-Bucau a écrit :
>>>
>>>> try adding a META-INF/scan.xml with
>>>>
>>>> <scan>
>>>> <packages>
>>>> <package>com.base.of.my.business</package>
>>>> </packages>
>>>> </scan>
>>>>
>>>>
>>>> Romain Manni-Bucau
>>>> Twitter: @rmannibucau
>>>> Blog: http://rmannibucau.wordpress.com/
>>>> LinkedIn: http://fr.linkedin.com/in/rmannibucau
>>>> Github: https://github.com/rmannibucau
>>>>
>>>>
>>>> 2014-05-12 16:36 GMT+02:00 david Cossé <cosse@codelutin.com>:
>>>>>
>>>>> Thanks for your help
>>>>>
>>>>> The project is build as this:
>>>>> lima
>>>>>     lima-buisiness
>>>>>       src/main/ressources/META-INF/ejb-jar.xml
>>>>>       pom.xml
>>>>>     lima-...
>>>>>       pom.xml
>>>>>     lima-swing
>>>>>       pom.xml
>>>>> pom.xml
>>>>>
>>>>> the pom from lima-swing has dependency to lima-business where is
>>>>> located
>>>>> the
>>>>> ejb-jar.xml
>>>>> but when launching the lima.jar from lima-swing the ejb-jar.xml file
>>>>> from
>>>>> lima-buisiness looks ignored.
>>>>>
>>>>> to build the project from the project root I do:
>>>>> mvn -U clean install
>>>>> then to launch id i do:
>>>>> java -jar lima-swing/target/lima-swing-0.8-SNAPSHOT.jar
>>>>>
>>>>> It works fine when using OpenEjb 4.5.2 but doesn't with 4.6.0.1
>>>>>
>>>>> thanks
>>>>>
>>>>> Le 12/05/2014 14:08, Romain Manni-Bucau a écrit :
>>>>>
>>>>>> Hi
>>>>>>
>>>>>> Do you do an uber jar? If so maybe think to add a scan.xml or ensure
>>>>>> the uber jar is well formed.
>>>>>>
>>>>>> Merging all jars can make think OpenEJB it has nothing to deploy
since
>>>>>> internal app is skipped and jar containing internal app is the same
as
>>>>>> your business one
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> Romain Manni-Bucau
>>>>>> Twitter: @rmannibucau
>>>>>> Blog:http://rmannibucau.wordpress.com/
>>>>>> LinkedIn:http://fr.linkedin.com/in/rmannibucau
>>>>>> Github:https://github.com/rmannibucau
>>>>>>
>>>>>>
>>>>>> 2014-05-12 13:59 GMT+02:00 david Cossé<cosse@codelutin.com>:
>>>>>>>
>>>>>>> After ugrading the openEJB version from 4.5.2 to 4.6.0.1, when
using
>>>>>>> java
>>>>>>> -jar to launch my application it doesn't start and throw up this
>>>>>>> exception:
>>>>>>>
>>>>>>> Erreur
>>>>>>>
>>>>>>> Message:
>>>>>>>        org.apache.openejb.OpenEjbContainer$NoModulesFoundException:
>>>>>>> No
>>>>>>> modules
>>>>>>> found to deploy.
>>>>>>> 1)Maybe descriptors are placed in incorrect location.
>>>>>>> Descriptors could go under:
>>>>>>> <base-dir>/META-INF or <base-dir>/WEB-INF
>>>>>>> but not directly under <base-dir>
>>>>>>> Check 'Application Discovery via the Classpath' docs page for
more
>>>>>>> info
>>>>>>> 2)Maybe no modules are present in the classpath.
>>>>>>> Is 'openejb.base' system property pointing to the intended location?
>>>>>>> Level:
>>>>>>>        SEVERE
>>>>>>> Stack Trace:
>>>>>>> No modules found to deploy. 1)Maybe descriptors are placed in
>>>>>>> incorrect
>>>>>>> location. Descriptors could go under:  /META-INF or /WEB-INF
but not
>>>>>>> directly under   Check 'Application Discovery via the Classpath'
docs
>>>>>>> page
>>>>>>> for more info 2)Maybe no modules are present in the classpath.
Is
>>>>>>> 'openejb.base' system property pointing to the intended location?
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> org.apache.openejb.util.Exceptions.newNoModulesFoundException(Exceptions.java:98)
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> org.apache.openejb.OpenEjbContainer$Provider.load(OpenEjbContainer.java:549)
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> org.apache.openejb.OpenEjbContainer$Provider.createEJBContainer(OpenEjbContainer.java:354)
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> javax.ejb.embeddable.EJBContainer.createEJBContainer(EJBContainer.java:56)
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> org.chorem.lima.service.LimaServiceFactory.initFactory(LimaServiceFactory.java:92)
>>>>>>>        org.chorem.lima.LimaMain.launch(LimaMain.java:136)
>>>>>>>        org.chorem.lima.LimaMain.main(LimaMain.java:88)
>>>>>>>
>>>>>>> Thanks for your help.
>>>>>>> David cossé
>>>>>>>
>

Mime
View raw message