tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vamsee Lakamsani <vam...@yahoo.com.INVALID>
Subject Re: @Injected field of a @Injected field is null
Date Wed, 04 Jun 2014 05:52:08 GMT
You are right. I pushed an update to my repo by adding a hello() business method. In the debugger
 MyDao becomes non-null when the method is entered. 
I do have a case in my larger app where I 'm seeing nulls even in the business method. Let
me see if I can reproduce that in this small app. 

Thanks. 


________________________________
 From: Romain Manni-Bucau <rmannibucau@gmail.com>
To: "users@tomee.apache.org" <users@tomee.apache.org>; Vamsee Lakamsani <vamsee@yahoo.com>

Sent: Tuesday, June 3, 2014 10:37 PM
Subject: Re: @Injected field of a @Injected field is null
 

works great on trunk.

side note: bean instantiation is not done while ejb *business* method is
not called for ejb and any method for cdi beans



Romain Manni-Bucau
Twitter: @rmannibucau
Blog: http://rmannibucau.wordpress.com/
LinkedIn: http://fr.linkedin.com/in/rmannibucau
Github: https://github.com/rmannibucau



2014-06-04 3:49 GMT+02:00 Vamsee Lakamsani <vamsee@yahoo.com.invalid>:

> I put together a small sample app here:
> https://github.com/lakamsani/cdi-nested
>
> MyResource is a JAX-RS service into MyService is @Injected
> MyDao is in-turn @Injected into MyService. When I run it (in TomEE
> 1.6.0.1),  MyDao is null inside the MyService instance injected to
> MyResource.  What do I need to do to make it work or is there another way
> of doing this (short of explicitly instantiating objects).
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message