tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Gumbrecht <agumbre...@tomitribe.com>
Subject Re: tomee redeployment issue
Date Thu, 19 Jun 2014 15:02:46 GMT
Helge,

It's still really cool that you do! Can't thank you enough for all your 
input.

It helps us an awful lot to track down the issues, but it looks like you 
have solved this already - I'd like to look at ways of making the 
resulting error more human readable though.

Andy.

On 19/06/2014 16:58, Helge Waastad wrote:
> No,
> I kind of used to providing test projects :-)
>
> https://github.com/hwaastad/BValEvaluation.git
>
> I think I've found out whats generating the issue:
>
> I have a custom constraintviolationmapper registered in openejb-jar.xml.
> If I remove this, the applications are deployed as usual.
>
> BTW, no tomee maven plugin in this project so you'll have to build and
> add/remove webapp1/webapp2 to a running 1.7.0 installation
>
> br hw
>
>
> On to., 2014-06-19 at 16:16 +0200, Andy Gumbrecht wrote:
>> I know it's maybe too much to ask, but can you provide an example/test
>> case project?
>>
>> Andy.
>>
>> On 19/06/2014 16:10, Helge Waastad wrote:
>>> Hi,
>>> I've from source now (e2a349b)
>>>
>>> and the issue is still present.
>>>
>>> Having only one webapp (using bval) I can redeploy without issues.
>>> Having more than one webapp, redeployment fails.
>>>
>>> br hw
>>>
>>> On to., 2014-06-19 at 12:27 +0200, Andy Gumbrecht wrote:
>>>> BeanValidationAppendixInterceptor has changed since 1.6.0 - And looks like
it should work now.
>>>> I'm going to change the exception catch to be more explicit.
>>>>
>>>> If you could run this on the snapshot and let me know if it broken that would
be cool. I doubt we'd invest time on the 1.6.x path to fix this with 1.7.x just around the
corner.
>>>>
>>>> Andy.
>>>>
>>>> On 19/06/2014 10:35, hwaastad wrote:
>>>>> Hi,
>>>>> I found out whats causing this issue.
>>>>>
>>>>> The error message is:
>>>>>
>>>>> Caused by: javax.naming.NameNotFoundException: Name "module/Object" not
>>>>> found.
>>>>>
>>>
>>>
>
>
>

-- 
   Andy Gumbrecht

   http://www.tomitribe.com
   agumbrecht@tomitribe.com
   https://twitter.com/AndyGeeDe

   TomEE treibt Tomitribe! | http://tomee.apache.org


Mime
View raw message