tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: error with maven: i tried to run with: package tomee:run
Date Thu, 05 Jun 2014 15:23:14 GMT
Hi

1.0.3-SNAPSHOT version doesn't exist. Use 1.6.0.2 for instance


Romain Manni-Bucau
Twitter: @rmannibucau
Blog: http://rmannibucau.wordpress.com/
LinkedIn: http://fr.linkedin.com/in/rmannibucau
Github: https://github.com/rmannibucau


2014-06-05 17:18 GMT+02:00 mauro2java2011 <mauro2java2011@gmail.com>:
> hi all .
> i  have tried to write a web tomee application with  the maven archetipe .
> *I have also tried to run with:
>
> package tomee:run *
>
> but i get the following message:
>
> No plugin found for prefix 'tomee' in the current project and in the plugin
> groups [org.apache.maven.plugins, org.codehaus.mojo] available from the
> repositories [local (/home/utente_javaee7/.m2/repository), central
> (http://repo.maven.apache.org/maven2)] -> [Help 1]
>
> To see the full stack trace of the errors, re-run Maven with the -e switch.
> Re-run Maven using the -X switch to enable full debug logging.
>
> For more information about the errors and possible solutions, please read
> the following articles:
>
> [Help 1]
> http://cwiki.apache.org/confluence/display/MAVEN/NoPluginFoundForPrefixException
>
>
> please how i can fix it ?????
>
> my pom.xml it is :
>
> <?xml version="1.0" encoding="UTF-8"?>
>
> <project xmlns="http://maven.apache.org/POM/4.0.0"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>          xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
> http://maven.apache.org/maven-v4_0_0.xsd">
>   <modelVersion>4.0.0</modelVersion>
>
>   <groupId>it.proveconmaven5</groupId>
>   <artifactId>mavenproject2</artifactId>
>   <version>1.0-SNAPSHOT</version>
>   <packaging>war</packaging>
>   <name>mavenproject2 TomEE Webapp</name>
>   <url>http://tomee.apache.org</url>
>
>   <dependencies>
>     <dependency>
>       <groupId>org.apache.openejb</groupId>
>       <artifactId>javaee-api</artifactId>
>       <version>6.0-5</version>
>       <scope>provided</scope>
>     </dependency>
>
>
>
>
>         <dependency>
>         <groupId>org.primefaces</groupId>
>         <artifactId>primefaces</artifactId>
>         <version>5.0</version>
>     </dependency>
>
>   </dependencies>
>
>   <build>
>     <plugins>
>       <plugin>
>         <groupId>org.apache.maven.plugins</groupId>
>         <artifactId>maven-compiler-plugin</artifactId>
>         <version>3.0</version>
>       </plugin>
>       <plugin>
>         <groupId>org.apache.maven.plugins</groupId>
>         <artifactId>maven-surefire-plugin</artifactId>
>         <version>2.13</version>
>       </plugin>
>       <plugin>
>         <groupId>org.apache.maven.plugins</groupId>
>         <artifactId>maven-war-plugin</artifactId>
>         <version>2.3</version>
>         <configuration>
>           <failOnMissingWebXml>false</failOnMissingWebXml>
>         </configuration>
>       </plugin>
>       <plugin>
>         <groupId>org.apache.openejb.maven</groupId>
>         <artifactId>tomee-maven-plugin</artifactId>
>         <version>1.0.3-SNAPSHOT</version>
>         <configuration>
>           <context>ROOT</context>
>         </configuration>
>       </plugin>
>       <plugin>
>             <groupId>org.apache.openjpa</groupId>
>             <artifactId>openjpa-maven-plugin</artifactId>
>             <version>2.2.0</version>
>             <configuration>
>                 <includes>**/entities/*.class</includes>
>                 <excludes>**/entities/XML*.class</excludes>
>                 <addDefaultConstructor>true</addDefaultConstructor>
>
> <enforcePropertyRestrictions>true</enforcePropertyRestrictions>
>             </configuration>
>             <executions>
>                 <execution>
>                     <id>enhancer</id>
>                     <phase>process-classes</phase>
>                     <goals>
>                         <goal>enhance</goal>
>                     </goals>
>                 </execution>
>             </executions>
>             <dependencies>
>                 <dependency>
>                     <groupId>org.apache.openjpa</groupId>
>                     <artifactId>openjpa</artifactId>
>
>                     <version>2.2.0</version>
>                 </dependency>
>             </dependencies>
>         </plugin>
>     </plugins>
>   </build>
>
>   <repositories>
>     <repository>
>       <id>apache-snapshot</id>
>       <name>Apache Snapshot Repository</name>
>       <url>https://repository.apache.org/content/groups/snapshots/</url>
>     </repository>
>
>
>   </repositories>
>
>   <properties>
>     <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
>   </properties>
> </project>
>
> ---------------------------------------
>
>
> also if i try with :
> mvn tomee:help
>
> i get :
>
> The POM for org.apache.openejb.maven:tomee-maven-plugin:jar:1.0.3-SNAPSHOT
> is missing, no dependency information available
> Failed to retrieve plugin descriptor for
> org.apache.openejb.maven:tomee-maven-plugin:1.0.3-SNAPSHOT: Plugin
> org.apache.openejb.maven:tomee-maven-plugin:1.0.3-SNAPSHOT or one of its
> dependencies could not be resolved: Failed to read artifact descriptor for
> org.apache.openejb.maven:tomee-maven-plugin:jar:1.0.3-SNAPSHOT
> Downloading:
> http://repo.maven.apache.org/maven2/org/codehaus/mojo/maven-metadata.xml
> Downloading:
> http://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-metadata.xml
>
> Downloaded:
> http://repo.maven.apache.org/maven2/org/codehaus/mojo/maven-metadata.xml (22
> KB at 14.3 KB/sec)
>
> Downloaded:
> http://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-metadata.xml
> (13 KB at 7.8 KB/sec)
> ------------------------------------------------------------------------
> BUILD FAILURE
> ------------------------------------------------------------------------
> Total time: 6.763s
> Finished at: Thu Jun 05 17:17:30 CEST 2014
> Final Memory: 7M/18M
> ------------------------------------------------------------------------
> No plugin found for prefix 'tomee' in the current project and in the plugin
> groups [org.apache.maven.plugins, org.codehaus.mojo] available from the
> repositories [local (/home/utente_javaee7/.m2/repository), central
> (http://repo.maven.apache.org/maven2)] -> [Help 1]
>
> To see the full stack trace of the errors, re-run Maven with the -e switch.
> Re-run Maven using the -X switch to enable full debug logging.
>
> For more information about the errors and possible solutions, please read
> the following articles:
> [Help 1]
> http://cwiki.apache.org/confluence/display/MAVEN/NoPluginFoundForPrefixException
>
>
>
>
>
>
>
>
>
>
>
>
> --
> View this message in context: http://openejb.979440.n4.nabble.com/error-with-maven-i-tried-to-run-with-package-tomee-run-tp4669907.html
> Sent from the OpenEJB User mailing list archive at Nabble.com.

Mime
View raw message